If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Data Access, Manipulation & Batch Languages > Crystal Reports > Only showing first record on table

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Mar 2012
Posts: 1
Only showing first record on table

Alright, so here's the problem and for the life of me I can't figure it out:

Task: Creating a report that lists all of our medically disabled employees. Must be a single line report (i.e. can not group and then list underneath).

Problem:
Some employees have more than one disability. This causes them to appear multiple times on the single-line report.

This is the table inside of my program that I am pulling from. This table is for a single employee. Notice how more than one disability is listed:
(See bardistable.jpg below)

This is the results of my report when I run it in Crystal:
(See reportresults.jpg below)

Somehow, I need to figure out a way to only show the first disability an employee has listed on their table. Like in employee 0077's case, I only want to see disability D02... not D04 and D05 too.

I DID find a solution to this by way of Section Expert > Suppress (No Drill-Down) > previous({hrpersnl.p_empno})={hrpersnl.p_empno}. But I can not use this formula because it causes my first employee to be suppressed for some reason.

Help please?
Attached Thumbnails
Only showing first record on table-bardistable.jpg   Only showing first record on table-reportresults.jpg  
Reply With Quote
  #2 (permalink)  
Old
Registered User
 
Join Date: Mar 2012
Posts: 12
Quote:
Originally Posted by Betsbabe View Post
Task: Creating a report that lists all of our medically disabled employees. Must be a single line report (i.e. can not group and then list underneath).

Problem:
Some employees have more than one disability. This causes them to appear multiple times on the single-line report.
From the menubar, choose Report > Group Expert and group by EmpNumber.

Go to Design Mode, grab the "Group #1 Name" (which should be in the Group Header #1), and pull it down to the Group Footer #1. Then grab the Disability Type which is in the Details section and drag it down to the Group Footer #1.

Right click on the Details item on the left and change it to "Suppress (No Drill-Down)". You'll probably want to do a little formatting changes, such as changing the "Group #1 Name" from boldface to lightface, but this should provide the output needed.

I would undo the effort taken with the Section Expert and return it to its default setting. HTH.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On