If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Informix > Error -951

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Aug 2002
Location: Quilmes
Posts: 3
Error -951

What is this error?

listener-thread: err = -951: oserr = 0: errstr = informix: Incorrect password or user informix is not known on the database server.

The user informix is setting good in the Informix instalation. I'm test with the user informix and her password for connect to motor. But testing without user and password and de connection is good.

Thanks
Reply With Quote
  #2 (permalink)  
Old
Registered User
 
Join Date: Feb 2002
Posts: 2,232
Which version of informix are you using ? Are you running under unix(which type/version) or windows (which type/version ? Have you looked at your release notes ? When does this error occur ?
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Aug 2002
Location: Quilmes
Posts: 3
Quote:
Originally posted by rnealejr
Which version of informix are you using ? Are you running under unix(which type/version) or windows (which type/version ? Have you looked at your release notes ? When does this error occur ?
Version 9.21 on Win2k. And this error occur on connection to database.
Thanks
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Aug 2002
Location: Belgium
Posts: 534
Hi,

How are you testing? Are you testing with a remote connection (ODBC?)
or just with dbaccess/CONNECTION tab?

If you use ODBC, don't forget that you have to 'trust your client machine on the server in c:\winnt\system32\hosts.equiv

In dbaccess, don't forget everything is case-sensitive. Check whether you defined the user informix with capital I or not. Stuff like that.
Check in the table sysusers to have a full user list.
__________________
rws
Reply With Quote
  #5 (permalink)  
Old
Registered User
 
Join Date: Aug 2002
Location: Quilmes
Posts: 3
Help... please!!!

I'm testing with dbaccess (in connection tab) and remote connection (ODBC). I'm test in the server machine (WIN2000). I'm check the case sentive in the user informix. And in the table sysusers i'm see the user informix good.
My test with user = null and pass = null is good!

Thanks!
Reply With Quote
  #6 (permalink)  
Old
Registered User
 
Join Date: Aug 2002
Location: Belgium
Posts: 534
Re: Help... please!!!

Ok, still not clear. When does the error occur?

1. ODBC Connection while connecting with a connection string from a windows client to a windows server.

2. dbaccess connection while using the connection tab and fill in user informix.

In both cases if you don't fill -in the user/pwd, you don't get an error?

Informix lets the os handle the user/pwd. So it is possible you created your username in the domain, but installed your infromixserver on the locale machine.
Try to create a user informix on the locale machine.

What are you setnet settings?
In your ODBC settings, can you execute the 'test connection' button?
__________________
rws
Reply With Quote
  #7 (permalink)  
Old
Registered User
 
Join Date: Oct 2002
Location: Buenos Aires
Posts: 7
Re: Error -951

It usually occurs when trying to connect from a DB server to another DB server

For example, johndoe@foo trying to connect to another server, and johndoe account does not exist in remote
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On