If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Microsoft SQL Server > Named Pipes Provider: Could not open a connection to SQL Server

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Aug 2010
Posts: 5
Named Pipes Provider: Could not open a connection to SQL Server

[2] => [Microsoft][SQL Server Native Client 10.0]Named Pipes Provider: Could not open a connection to SQL Server [53].
[message] => [Microsoft][SQL Server Native Client 10.0]Named Pipes Provider: Could not open a connection to SQL Server [53].
)

I see this in a wireshark trace when I try to hit our sql server from one of our pages. This is when trying to log into the site. I tried to enable named pipes and that did not help. I also tried repairing the installation of sql and that did not help. Also, I was able to start the SQL Browser in Windows services on that machine. But, when viewing the SQL Configuration, the SQL Browser was displayed as stopped. There was no instance name under the SQL connections. So, I tried to give the SQL Browser an object but I was not able to do so. So, there was still no instance name for the SQL Browser. Any ideas?
Reply With Quote
  #2 (permalink)  
Old
Wage drone 24601
 
Join Date: Jan 2003
Location: Massachusetts
Posts: 5,439
Go to the client machine, and run cliconfg.exe

I expect that the Named Pipes protocol will be first in the list. If it is, demote it, and promote TCP/IP.

Test the application thoroughly.

Check to make sure the errors have gone away.
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Aug 2010
Posts: 5
I do not think that is installed on this box. When I tried to run it from the command line, windows tells me it cannot find cliconfig.exe. Do I need something else installed to run this?
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Aug 2010
Posts: 5
I found the order. I am using SQL 2008. So, I found the client order under SQL Native Client 10.0 configuration. Named pipes is actually disabled. It is also disabled on the server. But, it was lower in the order anyways.
Reply With Quote
  #5 (permalink)  
Old
Wage drone 24601
 
Join Date: Jan 2003
Location: Massachusetts
Posts: 5,439
Cliconfg.exe does not have the second "i". The Native Client configuration will probably not affect older providers (such as OLEDB, or MSDASQL)
Reply With Quote
  #6 (permalink)  
Old
Registered User
 
Join Date: Aug 2010
Posts: 5
Ha, and I read something about that second 'i' in another forum.

Ok, great. I ran it and TCP/IP is the first in the list. Named pipes is second in the list. Both are enabled.
Reply With Quote
  #7 (permalink)  
Old
Wage drone 24601
 
Join Date: Jan 2003
Location: Massachusetts
Posts: 5,439
Hmm...Error 53 is can not find network path. Is it possible there is an application that has a bad config that is looking for a non-existent machine? It would fit, in that the tcp/ip library would fail. Then the request would pass down to named pipes, which would also fail.
Reply With Quote
  #8 (permalink)  
Old
Registered User
 
Join Date: Aug 2010
Posts: 5
That definitely could be the case. Part of the problem is that I came into this with the machine already set up. So, the web files were already installed onto the machine and the SQL server was already installed onto the machine. I just reverted to the snapshot in a program we are using for that. So, basically, I did not set the machine up. Which in turn means that your question is very valid and very possible. That is actually why I ran the network trace to begin with. Unfortunately, I do not know where to dig into the code to see where it was pointing to. I was hoping for any config file, but I only saw one and there was nothing relating to this in this file.

But, this is still good information go know. At least knowing what you said about error 53 points me in a possible direction.

Thanks so far. I will keep you posted.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On