If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Oracle > Actuate Report Error

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Jul 2008
Posts: 4
Actuate Report Error

Hi there

Following sql statement is working fine when i run on TOAD, but when i apply the same in Actuate report writer it gives me error
1) "Invalid string constant. "
2) Control character in string constant
3) "Actual: Else Expecting: '(', '+', '-', [currency constant],
[floating constant], [hexa constant], ID, [A-Z], [date constant],
[integer constant], Null, [octal constant], [string constant], ::, BNot,
ID@, ID#, ID%, ID&, ID!, ID$, New, Not, Nothing, Width "

I am using actuate professional 8.

SQL statement
"Select worksite, sum(REC_JA) from (select worksite,person.personid,
case when ( person.hiredate <= TO_DATE ( '15-JAN' || '-' || (TO_CHAR (CURRENT_DATE, 'YYYY')), 'DD-MON-YYYY') OR person.hiredate IS NULL) AND (person.status = 'ACTIVE' OR (person.status = 'INACTIVE') AND (person.terminationdate > TO_DATE('15-JAN' || '-' || TO_CHAR (CURRENT_DATE, 'YYYY')), 'DD-MON-YYYY') OR person.terminationdate IS NULL))
then 1
else 0
end as REC_JA from person, labor, laborcraftrate WHERE ( (person.personid NOT LIKE 'OF-%') AND (labor.laborcode = person.personid) AND (laborcraftrate.laborcode = labor.laborcode))) Group by worksite ORDER BY worksite ASC
"
Reply With Quote
  #2 (permalink)  
Old
Lost Boy
 
Join Date: Jan 2004
Location: Croatia, Europe
Posts: 3,986
I have never used the "Actuate Report", but - perhaps its engine doesn't know how to interpret the CASE expression.
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Jul 2008
Posts: 4
I have used CASE expression in few of my report and it is working.
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Dec 2003
Posts: 1,074
Is that the exact SQL statement that you're capturing in the ObtainSelectStatement() method?

--=cf
Reply With Quote
  #5 (permalink)  
Old
Registered User
 
Join Date: Dec 2003
Posts: 1,074
Actually, the more I think about it, that just sounds like an Actuate Basic error. I would take your question over to http://forums.actuate.com/, which requires that you're paying support to Actuate (and you have to contact them to get a login, I think).

I could help you find you a sol'n here, and you can set the ball rolling on getting an account in the Actuate Forums.

Have you tried following up the error to see if it's occuring somewhere else in your report? When it asks if you want to Debug, say YES. It'll say "No User Source". Then, click on Call Stack under the debug menu, it'll have a method highlighted in yellow, and then double-click on that message.

--=cf
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On