If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Oracle > Oracle 10g

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Americana, SP - Brazil
Posts: 5
Oracle 10g

Hi,

Forgive for my English, I am Brazilian.

I have one scheme with Red Hat 9, and I have installed the Oracle 10g also. I tried to have access my instance for the TORA and appeared the following message:

error ORA-12705 invalid or unknown NLS to parameter value especified.

After this I entered in mine .bash_profile and modified the variable for this parameter:

ORA_NLS33=$ORACLE_HOME/nls/data; export ORA_NLS33

Exactly thus I did not obtain success. I tried to force for saw sqlplus and also.
Somebody could say me as to skirt this error?

Since already I am thankful debtor.
Reply With Quote
  #2 (permalink)  
Old
Registered User
 
Join Date: Dec 2003
Location: Oklahoma, USA
Posts: 354
When setting ORA_NLS33 I've always seen it set as:

ORA_NLS33=$ORACLE_HOME/ocommon/nls/admin/data

Not sure if 10g changes this...

Another thing you might try is setting the NLS_LANG as:

NLS_LANG=BRAZILIAN PORTUGUESE_BRAZIL.WE8ISO8859P1

Hope this helps!

JoeB
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Americana, SP - Brazil
Posts: 5
I perceived this!

I looked for the ocommon/nls/admin/data and I did not find it, but I found it in /u01/ora10/nls/data.

I understood, I was configuring my NLS_LANG of this form:

NLS_LANG="brazilian PORTUGUESE_BRAZIL.WE8MSWIN1252"

I go to try of this form.

Thanx for the tip!
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Americana, SP - Brazil
Posts: 5
No,

it continues having the same problem..
Reply With Quote
  #5 (permalink)  
Old
Registered User
 
Join Date: Dec 2003
Location: Oklahoma, USA
Posts: 354
On UNIX systems, NLS_LANG must be uppercase. Also, if you are using double quotes, I don't think that will work. Try:

NLS_LANG=BRAZILIAN PORTUGUESE_BRAZIL.WE8MSWIN1252

not

NLS_LANG="brazilian PORTUGUESE_BRAZIL.WE8MSWIN1252"
Reply With Quote
  #6 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Americana, SP - Brazil
Posts: 5
Thanks!

It's working, however I had that to make download of the version most recent of the Tora!

Thanks again!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On