If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Pervasive.SQL > mkc library cannot be loaded

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Aug 2012
Posts: 3
mkc library cannot be loaded

I have a server using the pervasive sql v9 database with the program title express. Running windows server 2003. After a server reboot, I keep getting an error message when trying to open title express. It comes up on both the clients and server



I have looked around online and I read that I may have to re-register mkc.dll to resolve this issue? I am not familiar with pervasive or title express, and this just happened to come up when I was doing some network maintenance and installing antivirus on the server. This is very urgent, as I have a down customer that has to go to a settlement monday morning and he can't get to his title express program. Any help is appreciated.
Reply With Quote
  #2 (permalink)  
Old
Registered User
 
Join Date: Aug 2012
Posts: 3
I found the pvsw.log file that was mentioned in another thread. The error message started today, but here is the last few lines of the log.


08-21-2012 11:06:40 SQLManager 000008DC NTDBSMGR.EXE ACSERVER I -1073741805 Failure in disconnect (ACSTATION3) rc=-19.
08-21-2012 11:06:40 SQLManager 000008DC NTDBSMGR.EXE ACSERVER I -1073741805 Failure in disconnect (ACSTATION3) rc=-19.
08-21-2012 20:43:49 SQLManager 000008DC NTDBSMGR.EXE ACSERVER I -1073741805 Failure in disconnect (ACSTATION3) rc=-19.
08-22-2012 17:47:22 MKDE 000009C0 NTDBSMGR.EXE ACSERVER W Resources allocated
08-23-2012 10:19:25 SQLManager 000009C0 NTDBSMGR.EXE ACSERVER I -1073741805 Failure in disconnect (ACSTATION3) rc=-19.
08-23-2012 12:27:08 SQLManager 000009C0 NTDBSMGR.EXE ACSERVER I -1073741805 Failure in disconnect (ACSTATION3) rc=-19.
08-25-2012 15:47:16 MKDE 0000097C NTDBSMGR.EXE ACSERVER W Resources allocated
08-25-2012 15:57:55 MKDE 0000097C NTDBSMGR.EXE ACSERVER I Resources released
08-25-2012 16:10:01 MKDE 000007BC NTDBSMGR.EXE ACSERVER W Resources allocated
08-25-2012 16:16:27 MKDE 000007BC NTDBSMGR.EXE ACSERVER I Resources released
08-25-2012 16:52:57 MKDE 000007D8 NTDBSMGR.EXE ACSERVER W Resources allocated
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Dec 2001
Posts: 1,074
As far as re-registering MKC.DLL, you should be able to go to a command prompt, change to the Pervasive install directory (by default in v9 at C:\PVSW\BIN), and run the command "REGSVR32.EXE MKC.DLL".

I don't see anything specific in the PVSW.LOG that would indicate a problem with MKC.DLL.
__________________
Mirtheil Software
Certified Pervasive Developer
Certified Pervasive Technician
Custom Btrieve/VB development
http://www.mirtheil.com
I do not answer questions by email. Please post on the forum.
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Aug 2012
Posts: 3
Quote:
Originally Posted by mirtheil View Post
As far as re-registering MKC.DLL, you should be able to go to a command prompt, change to the Pervasive install directory (by default in v9 at C:\PVSW\BIN), and run the command "REGSVR32.EXE MKC.DLL".

I don't see anything specific in the PVSW.LOG that would indicate a problem with MKC.DLL.
regsvr32.exe c:\pvsw\bin\mkc3.dll

I ended up running this command prompt command that I found on another forum and it worked. The server is still running like crap, but Title Express is up and running and that's all that matters for now. Thanks for the help!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On