Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2004

    Unanswered: 450 MB db2syscs.exe magically disappears

    Hi all,

    I'm fairly new. Go easy.

    db v.8.1 on Windows XP Pro.

    I have a very interesting problem. And by interesting, I mean intensely frustrating.

    My database crashed as I was loading data into it. When I restarted the computer and tried to connect to the db, it hung at the db2 command prompt for around 5 minutes and then refused the connection saying no database manager had been started. When I typed 'db2start', it said that it started successfully, but the same thing happened when I tried to connect again.

    Upon further investigation, I realized that when I issue the db2start command and open the Windows Task Manager, there are 2 db2syscs.exe tasks listed. One is about 15K and the other is 450MB!!! The 450MB one stays up for about 5 minutes and then disappears.

    So when only the 15K db2syscs.exe task is running, I can't connect and it says no database manager is running. But if I issue the db2start command, the 450MB task initializes and then fails about 5 minutes later. During those 5 minutes I can connect to the sample database, but not to the database that I was loading data on. And I can't do anything to that database until the database manager is up and running.

    I believe that the database is going into crash recovery mode and then failing (confirmed by db2diag.log). But why are there 2 of these tasks, and is there no way to start the database manager even if crash recovery fails on one of the databases?

    Any help at all would be appreciated.

    Let me know if you need more detail.


  2. #2
    Join Date
    Apr 2004
    Inside Intel

    Question Edition

    What edition of DB2 are you running? As far i know, enterprise/connect editions of DB2 are not supported on XP professional. Although i did manage to install it without any problems, it would never allow me to import data from other machine onto XP.

    Last edited by dsusendran; 06-02-04 at 16:04.

  3. #3
    Join Date
    Jun 2004


    Enterprise edition.
    V.8.1 Service Pack 4.

    I've had no problems until now importing data. But why is the database manager not starting up?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts