Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2004

    Unanswered: Linux MySQL and Win32 ODBC

    Sorry if this question has been answered serveral times but I've searched for the last day trying to find an answer.

    I'm running mysql on a linux machine and want to access it from a Windows XP maching via ODBC. I've installed the windows mysql odbc drivers but when i attempt to configure them via Data Sources (ODBC) and press the Test Data Source i get "Can't connect to MySQL server on ..." I've tried using both the IP and the hostname in the configuration. Is there something i need to do to the mysql server to make it aware of the ODBC drivers?

    I can access mysql via apache and phpmyadmin which are running on the same machine as mysql but accessed from the windows machine. I've tried telnetting to port 3306 but it doesnt seem to be open. /etc/mysql/my.cfg lists 3306 as the port.

    Any Suggestions?

  2. #2
    Join Date
    Feb 2004
    In front of the computer
    Provided Answers: 54
    I'd start with basic TCP/IP connectivity testing. My guess would be that there is either a firewall or something like it that is causing your problems.

    Start by using ping to see if the Windoze box can see the MySQL server. If that works, try tracert to see what path the packets travel. Once you get to that point, then telnet might make some sense, but telnetting how and to what is unclear to me at this point!


  3. #3
    Join Date
    Jun 2004
    The windows box can definately see the linux box. I dont have a screen on the linux box and use putty to do everything. Tracert isnt going to help - the boxes are next to each other both physically and networcally. I ran nmap and port 3306 isnt listed as open. Could mysql be running but not opening a port? mysql is definately running though -
    mysqladmin -p ping
    Enter password:
    mysqld is alive

    I can't think of what I'm doing wrong.

  4. #4
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    >I can't think of what I'm doing wrong.
    You very well may not be "doing wrong" (an error of commission).
    I suspect that you are not doing something that needs to be done. (error of ommission).
    Have you granted remote access into the MySQL DB from the Windoze box?
    AFAIK, default privs/security is not enabled to allow access to the DB from any remote system.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Jun 2004
    It was indeed an error of omission. You were right - by default network access to the db is disabled.

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts