Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2004
    Posts
    4

    Unhappy Unanswered: Connection problem w/ Acceess & PostgreSQL server...

    Okay, I've been looking around for quite a while, here and in other forums/websites, and I don't think anyone else has come across this. Which either means it's very easy to solute, or very uncommon...

    So, I have a nice PostgreSQL database consisting of 19 tables and a whole bunch of foreign keys, primary keys etcetera. Now, most of the tables work fine when I 'link-tables' in Access 2003 (which is what my clients want to use) through the ODBC driver, but some of them (5 total) don't work. They report the error "ODBC: Call Failed" when opening and all fields are filled with the text "#Name?".

    The strange thing is is that he does know how many rows the table consists of as it fills himself that way. If I look at my postgreSQL DB through pgAdmin I also see that all data has been entered correctly. When the table is empty he also doesn't report an error.

    There is nothing (as far as I see it) special with the tables that don't work in relation to the ones that do work (apart from that they all have a reference to the table 'customer' but so do other tables that DO work).

    Can someone please help me find a solution? I'm almost sure it's something very simple (I haven't worked with the whole PostgreSQL-thing much yet) which I haven't seen...

    Every suggestion is much appreciated...
    Last edited by Niko; 06-06-04 at 13:06.

  2. #2
    Join Date
    Nov 2003
    Location
    Europe
    Posts
    369

    Arrow

    Best to get the question of object corruption out of the way first, and isolate the problem a bit:

    - could you try making a completely fresh/new access front-end, and reconnect to those 5 tables from it? Can you read the data from that front-end?

    If you can indeed read the data, try to delete those 5 linked tables from the original front-end and if not recreate them, IMPORT them from the new test front-end that just worked.
    (Not sure if it is relevant, but you could also try to right-click on one of them in the original front-end, choose Linked table manager, and try to refresh those 5 first.)

    D.

  3. #3
    Join Date
    Jun 2004
    Posts
    4
    hmm. I already refreshed (through the linked table manager) and made a new 'link' (new *.mdb) several times, but did not succeed. Also, when I try to link to just one of the 'broken' tables in a completely empty *.mdb it doesn't function either. But when I import it does, and also takes the data in it with him. Case is, I don't want to import them, I want to link them or the whole thing would be useless...

    I'm going to try to re-name all of the coloms in those tables to unique values and give them their own domain (which they aren't right now ("customercode"), but that shouldn't be a problem as they all are in different tables (transaction.customercode, payment.customercode, mutation.custermercode etcetera), so I don't have much hope but it's a method of eliminating 'object corruption' if that is relevant, it also 'occurs' in other tables so i don't see what I should cause a problem here).

    Thanks alot nevertheless Kedaniel, if you come up with any other possible solution I'd be very happy to read it

    Niko
    Last edited by Niko; 06-06-04 at 14:50.

  4. #4
    Join Date
    Jun 2004
    Posts
    4
    What do all five of my non-functional tables have in common that other tables don't?

    It isn't 'customercode' as that's used in different tables as well, noooo, it's a date object in a primary key! I bet you didn't saw that one coming...

    Now I am wondering why on the face of the earth this would not function, as I think it's very stupid and totally random.

    Whatever, thanks for the help kedaniel...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •