Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2004
    Posts
    3

    Unanswered: myODBC unable to connect

    Hi,

    I would appreciate help on the following.
    I have installed myODBC 3.51 on my Windows 2000 computer.
    I am trying to connect mysql database on a linux server.
    I configured the ODBC data source adminstrator from the
    administrative tools.
    After trying to add a new data source and entering all of the appropriate
    fields I get the error "Lost connection to MySQL server during query"
    The error shows up immediately.
    The only change I made was to change the port to 22.

    I use port 22 when I try to make a putty connection or WinSCP.
    I have no problems connecting to the server when using this method.
    I also don't have any problems connecting to the database after connecting with putty or using mysqlcc.

    I tried to used the default method of using port of 3306 and I get
    an error as well "Can't connect to MySQL server on ..."

    I found a tip about granting remote access and created a new user in mysql and granted permission
    for remote access by GRANT ALL on *.* to 'newuser'@ipaddressofwindowsmachine' by 'password' with grant option

    and then proceeded to connect with new user and password info but got the
    same errors. I didn't think this was a permission error since initially I
    was trying to login with the root user.

    I am not sure what the problem is?

    thanks very much.

  2. #2
    Join Date
    Dec 2003
    Location
    Houston, TX
    Posts
    21
    Maybe you have your Host set on that user account you are trying to connect with to localhost.

    Try setting up another user account who has their host Login Information set to your IP address or Any Host.

    The SQL is something like this

    Code:
    GRANT SELECT , INSERT , UPDATE , DELETE , CREATE , DROP , FILE , INDEX , ALTER ON * . * TO "blah"@ "%"IDENTIFIED BY "******"WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 ;
    The important part being the "%"
    Last edited by Leaden; 06-08-04 at 17:14.
    I do not fear computers. I fear the lack of them.
    -Isaac Asimov (1920 - 1992)

  3. #3
    Join Date
    Mar 2004
    Posts
    3
    thanks for the reply but I was careful to add the ipaddress to
    be that of the windows machine and to not just use localhost

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •