Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2004
    Posts
    23

    Unanswered: using a more recent JDBC driver for DB2 for V7.2

    I am using the driver COM.ibm.db2.jdbc.app.DB2Driver with DB2 version 7.2 on Windows 2000.

    It does not support some of the functionality I need with a third-party package. Can I use a slightly later version of DB2 driver? If yes, how and where do I find/get such a driver? What will be the driver-class/jar name etc?

    I don't need to be as recent as JDBC 3.

    Thanks

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    JDBC driver comes as a part of DB2 client software. To get a later fixpack version you'll need to download and install DB2 client package (you'll only need runtime client).

  3. #3
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    The drivers have to be at the same fixpack level as the rest of the client components.

    Never copy the jdbc driver packages to an alternate location or copy the driver from a different level of the product

    Cheers
    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  4. #4
    Join Date
    Jan 2004
    Posts
    23
    I appreciate your responses:

    I was at DB2 7.2 (without FixPack). Then I installed FixPack 12. That bumped the DB2 level from 7.2.0 to 7.2.9, but didn't get me the feature the third-party application needs: It throws exception when trying to:

    con.createStatement(ResultSet.TYPE_FORWARD_ONLY, ResultSet.CONCUR_READ_ONLY);

    Is this level of functionality simply not available at 7.2 level? Will this require me to go to DB2 V8? How can I find out?

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •