Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2004
    Posts
    10

    Unanswered: Need help in setting connection time out in Oracle 9i

    My firewall is causing problems in that it is causing me to have timeout problems when tyring to start my Oracle 9i database.

    The best solution is to reset my connect_timeout taht is to be found in listener.ora. But this has been replaced by initial_retry_timeout (I think) for Oracle 9i.
    initial_retry_timeout is to be found in sqlnet.ora in
    C:\oracle\ora90\networkADMIN\SAMPLE

    it is set to 30
    #name.initial_retry_timeout = 30

    There is another sqlnet.ora file in C:\oracle\ora90\network\ADMIN all these contains is:

    # SQLNET.ORA Network Configuration File: C:\oracle\ora90\network\admin\sqlnet.ora
    # Generated by Oracle configuration tools.

    SQLNET.AUTHENTICATION_SERVICES= (NTS)

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    I added the following line to this file restarted my PC but time out still took 30 secs.
    NAME.initial_retry_timeout = 5

    I dont have much experience of databases apart from writing sql and store procedures.

    So I have no idea apart from pure guess work in trying to sort this problem out.

    Thanks for any help.

    Tony

  2. #2
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    Have you looked into profiles? Set up a profile with timeout values and assign users to the profile ...

    HTH
    Gregg

  3. #3
    Join Date
    Sep 2003
    Location
    Virginia, USA
    Posts
    246
    It sounds like your problem is you don't want timeouts to occur, but the firewall causes them. Try this. Edit file sqlnet.ora and add the line sqlnet.expire_time = 10 (or any number of seconds.) You must make the same change on your client and server's sqlnet.ora file. This parameter tells client and server to ping each other every N seconds, which tricks the firewall into thinking you are active.
    MarkRem
    Author, Oracle Database 10g: From Nuts to Soup
    http://www.remidata.com/book_nuts2soup.htm

  4. #4
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    Ooops.... I missed the part about the firewall ... Mark is correct, set expire_time ...

    Gregg

  5. #5
    Join Date
    Feb 2004
    Posts
    10
    Thanks lads that has sorted my problem out, thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •