Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2004
    Posts
    8

    Angry Unanswered: <longtext> problem !!!!!

    I have read a million posts about this over the Internet

    I have a SQL Server 2000 (sp3 ) table. In the table I have an ntext comments field. In about 4 records, the comments field shows <longtext>

    The problem is that my ASP spits out nothing for the comments field for any records that have <longtext> in its comments field. Furthermore, I have tried the following with no luck

    1) Tried putting comments field at end of the SQL Statement...it was already there anyway
    2) Tried using GetChunk...my app doesn't like that command and doesn't recognize it

    The weird thing is that in Production, I have a live version of my ASP page which works fine. It can call the sub in question, run the query and spit out the records including ones with <longtext> just fine. Then I shove it into an array and then use XML to read the array values and spit out the data to Excel.

    When I took a copy from production of my app, added 4 subs and then tried again, my application no longer likes longtext and when it renders records with longtext to the screen in their comments field, the comments field shows nothing.

    Now the 4 subs are completely unrelated and have not affect on the sub that is having the problem spitting out the comments fields to ASP (Response.Write Query("comments")) to the screen. Why does my modified app not like records with <longtext>, I don't know.

    One of the fields that has <longtext> can be rendered just fine by doing a Response.Write Query("comments") in another app we have that is unrelated to this app.

    Why can't my app read these records?

    here is part of my code:

    strSQL = "SELECT CE_Id, '' as CEName, Case_Id, Email_To, CONVERT(CHAR(10), Date_Answered, 101), Comments FROM tbl_Survey where Date_Answered BETWEEN '" & Trim(Request.QueryString("RestrictDate1")) & "' AND '" & Trim(Request.QueryString("RestrictDate2")) & "'"
    Set Query = objConnection.Execute(strSQL)

  2. #2
    Join Date
    Dec 2003
    Posts
    454
    Did you try to remove the 4 subs and see if your application works? Your query statement looks not correct.

    strSQL = "SELECT CE_Id, '' as CEName, Case_Id, ....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •