Results 1 to 2 of 2
  1. #1
    Join Date
    May 2004

    Unanswered: Corrupted database! Help!

    On Friday night I finished my database, set it as a zip file and saved various copies on my computer, flash drive and then sent copies to various of my friends for safeguarding.

    Today I edited the copy that hadn't been zipped. I basically edited the layout of some forms. Nothing hugely technical. But then I tried running one of the queries that had previously worked and it came up with 'Microsoft Access has encountered an error. Send Error Message Report?' (and then it gave me the option of Repairing and Restarting Microsoft Access). I did this but nothing changed.

    I thought, oh dear, something's funny with my computer. So I tried it on a different one. Same thing. The query I ran comes from a form (that is, the criteria in the query are from the input boxes on a search form). The trouble arose when I clicked the 'Search' button on my form (and again, when I tried running the query itself, both in Query and Design view). So I tried exporting the form and query from the zipped copy of the database, which worked fine. Still nothing changed.

    The confusing part came when I tried extracting the files in the zip file to a different folder and then run that again. While there is no error message if you run the query from the database while in the zip folder, there is of course an error message when it's run from the extracted copy.

    I also tried running the database from the zipped copies I'd placed in other locations and on other computers. Nothing changed. It still worked in the zip file, but not when extracted.

    I also tried deleting the query itself and redesigning it with the original SQL code. Of course, when I tried this, it didn't work either. Still an error message.

    All other queries work fine; I tried repairing the database, extracting it, editing, exporting, copying, pasting and everything else. Access itself alluded the fact that the file was corrupted. Trouble is that I don't have another copy, and I'm assuming that the query must have been corrupted even before I zipped it up. Of course, I didn't think to check it before doing so because a) it had always worked fine and b) I hadn't made any recent changes to it.

    Can you help? Many thanks,

    - Grace

  2. #2
    Join Date
    Sep 2003
    Did you try creating a new database and importing all of your objects from the old one?

    Also, try compiling your code ...
    Back to Access ... ADO is not the way to go for speed ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts