Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2004
    Posts
    2

    Unanswered: Problems in installing and configuring PostgreSQL

    Hello All

    I compiled the PostgreSQL using the commands rpm -ivh *.rpm and installed it but as I want to install DSpace I have to follow the steps as follows

    Once installed, you need to enable TCP/IP connections (DSpace uses JDBC). Edit postgresql.conf (usually in /usr/local/pgsql/data or /var/lib/pgsql/data), and add this line:

    tcpip_socket = true

    Then tighten up security a bit by editing pg_hba.conf and adding this line:

    host dspace dspace 127.0.0.1 255.255.255.255 md5

    Then restart PostgreSQL.

    But I could not find the file postgresql.conf in either of the directory as suggested.

    So I tried to erase the PostgreSQL using rpm -e *.rpm and it gave an error message that Postgre ... packages not installed

    so I tried rpm -i *.rpm and its message was more shocking saying that its already installed.

    Thanks and hope a help from you soon.
    Shabbir Bhimani

  2. #2
    Join Date
    Jun 2004
    Posts
    2
    Hello

    I found the solution myself and is replying here to just let anyone help who faces the same problem.

    Run initdb file to initialize the database and populate the data folder with the files needed.

    Thanks
    Shabbir Bhimani

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •