Results 1 to 3 of 3

Thread: ASP Forms

  1. #1
    Join Date
    Jun 2004
    Posts
    1

    Unhappy Unanswered: ASP Forms

    Hi I am trying to get a simple form in asp running and everytime I upload the page to the server and view it, I receive this message:

    Microsoft JScript compilation error '800a03ec'
    Expected ';'
    /proto/form.asp, line 1

    I want a user to be able to fill out the form and submit it and it get emailed to me - I am using this tutorial:
    http://www.dwfaq.com/Tutorials/Forms/asp_form1.asp

    Maybe I filled out this code wrong:

    <%@LANGUAGE="VBSCRIPT"%>
    <% fromName="Webade.co.uk" fromAddress="form@webade.co.uk" toName="Design" toAddress="webmaster@webade.co.uk" subject="Website Feedback Form" relay="smtp.yourhost.net" %><html>

    Can someone please shed some light on this?

  2. #2
    Join Date
    Nov 2003
    Location
    Christchurch, New Zealand
    Posts
    1,618
    From what you have provided I don't think we can help at all. Can you post the entire form.asp page so that we can see exactly what you are doing?

    There is an interesting mismatch here... you are writting in vbscript but the error is reporting that it is jscript....

  3. #3
    Join Date
    Jan 2002
    Posts
    189
    Yeah, this is a bit weird. A JScript compiler would certainly throw exactly that error on seeing that code, but the JScript compiler shouldn't be looking at it at all. What server setup is this on? Anything... odd.. about it? Something installed on it that's said it owns ASP files rather than IIS? This IS an ASP file you're trying to run, isn't it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •