Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2003
    Posts
    39

    Unanswered: Record appear differen on different sqlplus interfaces

    One particular record (in english) show different on different
    sqlplus interfaces.
    See the first line below in output.

    SQL> select * from a ;
    CONTENT1_TEXT
    ------------------------------------------------
    Pay someone not on my payee listâ¦
    Someone on my payee list
    Someone on my payee list

    SQL>

    On the first record... there are 3 periods(.) at the end but it is showing some "a umlut" charactor.

    This is in english laguage with database charactor set is AL32UTF8
    the datatype of CONTENT1_TEXT is CLOB

    - But if I view this in the i-sqlplus or in OEM it shows values as
    below. can anyone imagine why this behaviour is happening.

    Pay someone not on my payee list…
    Someone on my payee list
    Someone on my payee list


    ---------------------------------------
    Here is the export dump.
    TABLE "A"
    CREATE TABLE "A" ("CONTENT1_TEXT" NVARCHAR2(2000)) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 STORAGE(INITI
    AL 65536 FREELISTS 1 FREELIST GROUPS 1) TABLESPACE "TS_CITI" LOGGING NOCOMPRESS
    INSERT INTO "A" ("CONTENT1_TEXT") VALUES (:1)
    *ĐBPay someone not on my payee list &0Someone on my payee list0Someone on my payee list6
    ˙˙
    EXIT
    EXIT
    -----------------------------------

    Any thoughts

    Thanks
    Yuwaraj

  2. #2
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    Check out your GLOGIN.SQL script in your Oracle Home for any NLS settings... or you might want to set NLS to be set.

    GLOGIN.SQL is in your $ORACLE_HOME\sqlplus\admin directory.

    JoeB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •