Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2003
    Posts
    49

    Unanswered: Installing Oracle - ORA-01034 ORACLE NOT AVAILABLE

    hi everybody,
    i'm trying to install a second instance on Oracle8.1.7 on Sun Enterprise 250 (with Solaris 8).
    the previous instance has this init.ora file:
    ******
    open_cursors = 300
    max_enabled_roles = 30
    db_block_buffers = 10240
    shared_pool_size = 52437800
    large_pool_size = 614400
    java_pool_size = 20971520
    log_checkpoint_interval = 10000
    log_checkpoint_timeout = 1800
    processes = 270
    log_buffer = 163840
    timed_statistics = true # if you want timed statistics
    max_dump_file_size = 10000 # limit trace file size to 5M each
    db_block_size = 8192
    local_listener = "LISTENER_VCOPROD"
    distributed_transactions = 75
    open_links = 5
    # mts_dispatchers = "(PROTOCOL=TCP)(PRE=oracle.aurora.server.SGiopServ er)"
    # Uncomment the following line when your listener is configured for SSL
    # (listener.ora and sqlnet.ora)
    # mts_dispatchers = "(PROTOCOL=TCPS)(PRE=oracle.aurora.server.SGiopSer ver)"
    sort_area_size = 4194304
    sort_area_retained_size = 4194304
    db_file_multiblock_read_count = 32
    hash_multiblock_io_count = 8
    transactions_per_rollback_segment = 25
    ******
    please, notePROCESSES is 270 (not the default)


    and i'm trying to set the following parameters on the new instance:
    dedicated server mode
    db_block_buffers 16.384
    shared_pool_size 83.886.080
    processes 150
    log_buffer 655.360
    open_cursors 1.024
    sort_area_size 1.048.576
    sort_area_retained_size 1.048.576

    this is my /etc/system:
    ** Kernel Parameters on our SUN Enterprise with 640MB for Oracle 8.1.x*
    set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=100
    set shmsys:shminfo_shmseg=10
    set semsys:seminfo_semmni=70
    set semsys:seminfo_semmsl=500
    set semsys:seminfo_semmns=1500
    set semsys:seminfo_semopm=100
    set semsys:seminfo_semvmx=32767


    but as the "create database" starts, i get the ORA-01034 ORACLE NOT AVAILABLE error.
    i found this info in the crdb1.log:

    Connected.
    ORA-00101: invalid specification for system parameter MTS_DISPATCHERS
    CREATE DATABASE "ADS"
    *
    ORA-01034: ORACLE not available
    Disconnected.

    but why do i have the MTS_DISPATCHERS paramenter if i set dedicated server mode? i guess i don't need MultiThreading...


    anyway, are the semmsl, semmni, semmns parameters correctly configured? i rememeber i had a similar error and these parameters were to set correctly to make it work, but this time i can't find out the point!!!

    please, it's very urgent...

    thankx a lot!

    matte

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Below is from one of my Sun systems which supports 5 instances
    * oracle stuff
    set semsys:seminfo_semmap = 200
    set semsys:seminfo_semmni = 200
    set semsys:seminfo_semmns = 8192
    set semsys:seminfo_semmnu = 30
    set semsys:seminfo_semmsl = 8192
    set semsys:seminfo_semopm = 10
    set semsys:seminfo_semume = 10
    set semsys:seminfo_semusz = 96
    set semsys:seminfo_semvmx = 32767
    set semsys:seminfo_semaem = 16384
    set shmsys:shminfo_shmmax = 4294967295
    set shmsys:shminfo_shmmin = 1
    set shmsys:shminfo_shmmni = 1000
    set shmsys:shminfo_shmseg = 128
    * end of oracle stuff

    HTH & YMMV
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •