Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2004
    Posts
    10

    Unanswered: Instance lockup after List Applications All

    We have DB2 AIX V8.1. I was signed on as the instance owner in the control center. I needed to do a force applications all and start a backup of a particular DB on that instance. I left the control center running, and I logged on to the AIX box as the same instance owner as my control center session. I ran the following commands on the box.

    DB2 Force applications all (this of course is async)
    Waited about 10 seconds then:
    DB2 List applications

    The "List applications" locked up and we could not connect to DB2 with any users. I waited about 10 minutes and tried to slam the control center window. This did not help. This may be due to the fact that my session on the AIX box that was trying to kill the control center and other users was having trouble with the fact that the Logged on ID in the control center was the same as the ID on the AIX box requesting a force. Meaning, it doesn't do well when attempting to kill itself.

    The instance remained locked up. We worked with our systems admin to try to kill processes in hopes that we wouldn't have to bounce the box. He was able to identify and kill process "DB2TCPCM" that seemed to fix things. Once he killed it, we were able to stop/start the instance and connect to the database.

    Has anyone run across this before? DB2 does allow you to sign on with multiple sessions as the same id. I think that DB2 should be able to handle this without locking up the instance. Any ideas?
    Last edited by AD29; 06-23-04 at 18:03.

  2. #2
    Join Date
    Jun 2004
    Posts
    10
    ??????????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •