Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2004
    Posts
    5

    Question Unanswered: I have this error...."Login failed for user"(But sometimes only)

    Hi

    I have IIS Web server and SQL database server on my PC.
    When I run my ASP page, sometimes I got the error....

    Error Type:
    Microsoft OLE DB Provider for ODBC Drivers (0x80040E4D)
    [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'MYPC\IUSR_MYNAME'.

    What puzzled me is that I don't get this error all the time. For the same program, and same configuration, sometimes it turned out okay but sometimes I got this error.

    I used mix authentication for SQL database.

    Please help me with this...(I am very new to sql database)

  2. #2
    Join Date
    Feb 2004
    Posts
    492
    I would think it's a network issue, hows your network properties?

  3. #3
    Join Date
    Jun 2004
    Posts
    5
    But I installed both servers in my standalone PC.

  4. #4
    Join Date
    Feb 2004
    Posts
    492
    so your running both sqlserver as iis on the same system? would it be possible to reconfigure iis to use a sql-account instead?

  5. #5
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    It may be you are losing contact with the domain controller. Next time this happens, see if you can ping the DC from both your client, and the server.

  6. #6
    Join Date
    Jun 2004
    Posts
    5
    Previously, I used local system account for bother servers and dsn file configurations.

    After I changed to non-local system account for IIS server, the IIS server is not running anymore.

  7. #7
    Join Date
    Jun 2004
    Posts
    5
    domain controller.... but both servers are in 1 PC. I am testing on my standalone PC(not in the network).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •