Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2004
    Posts
    8

    Unanswered: Microsoft VBScript runtime (0x800A004C)-Path not Found

    Error Type:
    Microsoft VBScript runtime (0x800A004C)
    Path not found
    /ValleyForms/excel1.asp, line 44
    __________________________________________________ __
    Hello, Anyone know how to resolve this error?
    **this line here is what I think its refering too, but why?

    Set act = fso.CreateTextFile(server.mappath("write2htm/"&g_filename & "-"& month(date())& day(date())& year(date()) &".htm"), true)

    Thank you

  2. #2
    Join Date
    Jun 2003
    Location
    USA
    Posts
    1,032
    Perhaps try changing this:
    server.mappath("write2htm...

    To be more like this instead:
    server.mappath("/write2htm...
    Last edited by Bullschmidt; 07-01-04 at 20:58.
    J. Paul Schmidt, Freelance Web and Database Developer
    www.Bullschmidt.com
    Access Database Sample, Web Database Sample, ASP Design Tips

  3. #3
    Join Date
    Apr 2007
    Posts
    2

    0x800A004C - CTL_E_PATHNOTFOUND as an intermittent fault

    After having spent months developing a browser app using VB.NET and SQL Server that will happily use FSO for all sorts of disc accesses for me, I have now let it loose on some test users, and frequently, (but not always!) they will get the 0x800A004C - CTL_E_PATHNOTFOUND error.

    I have a mapped drive to the app server, they do not as it wouldnot be sensible to provide them with this sort of access.

    We are all mystified.

    Plainly permissions are set sufficiently well so that both I and the test users can access directoriea dn files on hard discs over three servers.

    One instance of the error, reported through Try/Catch:
    System.IO.DirectoryNotFoundException: Exception from HRESULT: 0x800A004C (CTL_E_PATHNOTFOUND). at Scripting.FileSystemObjectClass.GetFolder(String FolderPath) at DDA.FSOClass.GetSubfolders(String FolderName) in \\nas-dda-01\wwwroot$\DDA\FSOClass.vb:line 625 at DDA.Workflow1.ddlInboxStatus_SelectedIndexChanged( Object sender, EventArgs e) in \\nas-dda-01\wwwroot$\DDA\Workflow1.aspx.vb:line 645

    The code seems to work fine about 80% of the time. Any ideas?

  4. #4
    Join Date
    Apr 2007
    Posts
    2

    Mystery solved

    I have had word today from the Infrastructure Team that they "can confirm that the problem was due to NTFS and local group permissions on this server."

  5. #5
    Join Date
    Jan 2009
    Posts
    1
    Did they ever give you any work around? I'm trying to use FileSystemObject programmatically in VFP, and I can't figure out why it sometimes works and sometimes reports 0x800A004C (the folder being copies is always there.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •