Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2004
    Posts
    10

    Unanswered: Turning off formatting

    Hi

    I am basically calling a sql script from a unix shell script.

    Contents of my ksh file:
    isql -U -P -S -s "," -i script_file_name -o output.csv
    Well, the problem is that the formatting screws up how the csv file looks.

    In oracle, you can use set feedback off and set pagesize 0 and it gives you perfectly formed csv files.

    How can I do it with Sybase?

    Thanks.

  2. #2
    Join Date
    Feb 2004
    Posts
    28
    Try adding following option to isql:
    -w 9999

    Also, in input file, add following line in the begining:

    set nocount on
    go


    J

    Quote Originally Posted by dvskid
    Hi

    I am basically calling a sql script from a unix shell script.

    Contents of my ksh file:


    Well, the problem is that the formatting screws up how the csv file looks.

    In oracle, you can use set feedback off and set pagesize 0 and it gives you perfectly formed csv files.

    How can I do it with Sybase?

    Thanks.

  3. #3
    Join Date
    Jun 2004
    Posts
    10
    Hi

    Thanks for the reply. I already have set nocount on and that takes care of turning off the feedback.

    I'll see what -w9999 does. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •