Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2004
    Posts
    2

    Exclamation Unanswered: Replication doesn't replicate

    Ok, I'm knee-deep in replication-hell.

    I'm trying to set up snapshot replication between two SQL Server 2000 databases over the internet. Both servers run Windows 2000 server edition and SQL server 2000. The idea is to send certain local information, stored in database tables to a database from which the information is published on a website.

    I've set up the distribution database (with the original name: distribution) and connected a publisher to it (let's call that one "source_database") using the sp_adddistpublisher stored procedure. No problems there...
    Next step, I added a publication, the tables in source_database, and a subscriber, the website database. I've opened up port 1433 on both servers, but still it won't send anything from the source_database to the website database....

    It gives no errors, but just doesn't do anything...
    Now, I've looked for possible problems and I think these problems might be able to cause problems:
    - The initial snapshot is not reaching the subscriber
    - I've made a push subscription which may has to become a pull subscription
    - The RPC's aren't available, because both servers are highly secured
    - The wrong serverpack is installed (this one is a wild guess)

    Does anybody have any idea on how I can get my distribution working or solve any of the problems above, cause I'm running out of idea's....
    (P.S. I'm a bit of a noobie to replication, I've set it up in a test environment before and it just worked perfectly, but the real thing isn't)

  2. #2
    Join Date
    Sep 2003
    Location
    Dallas, Texas
    Posts
    311
    You may have already done it, but just to make sure that you have define the publisher and the subscriber in the source server, right? Does your source server know the network id of the target server? Simply try to register the target server's name on EM of the source to see.

  3. #3
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Service pack will get you bad. I experimented with 2 servers running 194 and 818 builds, and was getting nothing, no matter what I tried. And when you apply SP3 you'd notice that there are scripts that directly affect replication (repl*.sql)
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  4. #4
    Join Date
    Jul 2004
    Posts
    2
    I solved the problem....
    It did turn out to be the service pack.
    Sp3a was installed by a sys-admin, but not correctly.
    After re-installing Sp3a everything just started working.

    Man, I'm glad that one's solved, I had like 5 minutes left till insanity...

    Anyhow, thanx for the help...

  5. #5
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    Quote Originally Posted by SemTeK
    Man, I'm glad that one's solved, I had like 5 minutes left till insanity...
    Oh, so you aren't really a dba yet??? Actually, once I gave up on the sanity part, the rest seemed a lot easier!

    -PatP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •