Results 1 to 1 of 1
  1. #1
    Join Date
    Jul 2004
    Posts
    1

    Unanswered: Cannot connect to Oracle through IIS 5.0 (can through IIS 4.0)

    I'm hoping someone may be able to help me. I am on the point of insanity working on this, as well as our Network Engineer and the Web Developer.

    Our webhost is still running NT 4.0 on a prehistoric machine, connecting to Oracle 8i. They have given us the option to upgrade to 2000 on a much better machine, connecting to Oracle 9i. However, my boss wanted me to test the sites on a 2000 server here (connecting to our Oracle 9i server), before we agree to the upgrade.

    I cannot get the sites that connect to Oracle working on the 2000 server. I feel it is a setup issue, but the Network Engineer has reinstalled MDAC 2.8, IIS, Oracle client software and who knows what else.

    I have tried all of the following connections, without any success:
    • cnn.Open "DSN=webconnection;UID=WEBADMIN;PWD=PASSWORD"
    • cnn.Open "Provider=OraOLEDB.Oracle;USER ID=WEBADMIN; PASSWORD=PASSWORD;DATA SOURCE=DATABASENAME"
    • cnn.open "Driver={Microsoft ODBC for Oracle}; Server=DATABASENAME; Uid=WEBADMIN; Pwd=PASSWORD"
    • cnn.Open "Provider=MSDAORA;User ID=WEBADMIN; Password=PASSWORD;Data Source=DATABASENAME"


    The last connection string (MSDAORA) works perfectly on the webhost's NT server connecting to their Oracle 8 server. This connection string works perfectly on our NT server, connecting to our Oracle 9 database. However, it fails when on the 2000 server connecting to our Oracle 9 database.

    An error is never produced, it just never loads anything (even after letting it sit for several hours, it still appears to be trying to connect). I've done numerous searches and cannot find anyone with the same issue (most issues I found actually gave an error, unlike our situation.)

    Web pages that connect to Access or mySQL databases work perfectly on our 2000 server. It's only the Oracle connections that fail.

    However, on the 2000 server, I can connect to the Oracle server through Access, using the same Datasource referenced in the first connection string above.

    I do not have any experience setting up IIS, so I am at a loss if it is a setting in it. Our Network Engineer says we'll try calling Microsoft later this week if we can't get this resolved.

    I've tried to be as descriptive and complete as possible, if anyone has any suggestions or tips, PLEASE let me know. I am almost to my breaking point with this project!!
    Last edited by amyd; 07-13-04 at 18:37.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •