I accidently droped one of my databases in mysql control center and I thought I could just restore my backup but it only seems to restore the structure and some of the data.

To restore my database I just copied all the files in the data/databasename folder from a backup I had burned to cd. This seemed to work ok but I tried to select from the tables I was receiving the error on some of them:

ERROR 1016: Can't open file: 'forum_users.MYI'. (errno: 130)

So I tried repairing these tables but they only seem to be able to restore the structure I tried running myisamcheck -r

myisamchk: error: 'c:\mysql\data\database\table.MYI' is not a MyISAM-table

Even though they are myISAM tables, And mysqlcheck -r unichat which gives me

error : Can't open file: 'forum_themes.MYI'. (errno: 130)

Could my files have been corrupted when they got burnt to cd? Strange how I can restore some of the tables though just a few that I can't.

What else can I do besides mysqlcheck and myisam check I've tried all the different options with them but nothing works.

HELP! thanks

I'm using winxp and mysql 4.0.16