Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2003
    Posts
    268

    Unanswered: OLAP connection problems

    I have two systems setup with SQL Server 2000 + Analysis Services. Both servers have been patched with both SP3a patches.

    I wrote a trivial command line app that tests connection strings through ADO.

    On each system, I can connect locally perfectly using the connection string:
    "Provider=MSOLAP;Data Source=localhost;Initial Catalog=FoodMart 2000"

    However, once I change "Data Source" to refer to the other system, the call to ADODB.Connection.Open throws a "System.Runtime.InteropServices.COMException" with message: "Unspecified error". (The simple app is written in C# and talks to ADO through Interop)

    I've tried referencing ADO 2.1, ADO 2.5 and ADO 2.7
    I've tried a "Provider" of "MSOLAP.2" as well as just "MSOLAP"
    I've also tried a variety of different connection strings with many different permissions settings.

    It is very frustrating to get an absolutely generic error message.

    Any ideas?

    Thanks in advance!

  2. #2
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Have you tried adding "User ID=xxx;Password=xxx"

    or

    "Integrated Security=SSPI"
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  3. #3
    Join Date
    Oct 2003
    Posts
    268
    Yes, just retried all of them and they all result in the same System.Runtime.InteropServices.COMException, "Unspecified error"

    adomdtest "Provider=MSOLAP;Data Source=localhost;Initial Catalog=FoodMart 2000"
    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;Initial Catalog=FoodMart 2000"
    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;Integrated Security=SSPI;Initial Catalog=FoodMart 2000"
    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;User Id=sa;Password=xxxx;Initial Catalog=FoodMart 2000"

  4. #4
    Join Date
    Oct 2003
    Posts
    268
    Let me reclarify. This one works fine:

    adomdtest "Provider=MSOLAP;Data Source=localhost;Initial Catalog=FoodMart 2000"

    These (that reference another system) fail with System.Runtime.InteropServices.COMException, "Unspecified error":

    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;Initial Catalog=FoodMart 2000"
    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;Integrated Security=SSPI;Initial Catalog=FoodMart 2000"
    adomdtest "Provider=MSOLAP;Data Source=192.168.128.53;User Id=sa;Password=xxxx;Initial Catalog=FoodMart 2000"

    I experience the same effect from two systems; either system can open its own database but can't open a remote one.

  5. #5
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Can't think of anything here...Maybe these links can give you some ideas?

    http://msdn.microsoft.com/library/de...shoot_8wfm.asp

    http://msdn.microsoft.com/library/de...shoot_64fb.asp
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •