Results 1 to 2 of 2
  1. #1
    Join Date
    May 2004

    Unanswered: DB Link dissconnect

    We are having 3 different version of oracle ( oracle 7.3, 8.1 and 9.2) on one M/C. The default listener version is O9i.
    Some of my colleagues are facing problem in accessing db link. For unknown reason, the link is not active for some time and then it become active.
    The user is getting the following error when he runs a query (currently he is using O8i DB and remotely accessing O9i DB. The default ver. of listener in remote DB is also O9i)
    ERROR at line 1:
    ORA-04052: error occurred when looking up remote object SURVEY@TTSD.WORLD
    ORA-00604: error occurred at recursive SQL level 1
    ORA-02068: following severe error from TTSD
    ORA-03114: not connected to ORACLE

    Any idea for this problem


  2. #2
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    V9.2 DB can't talk to a V7.3 DB & vice versa.
    IIRC, you'll need to use the V8.1 listener to successfully interoperate with all 3 versions.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts