Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2004
    Posts
    5

    Question Unanswered: [Q] MS Access Database Date Format

    Hey all, I'm an Access beginner. I met with a problem and can't solve it.

    Currently, I have a field in the table stored Date/Time data. In table's design view, I set the Format as dd/mm/yy and set the Input Mask as 99/99/00. To match the table, I set up a textbox in the form, and set the textbox format to dd/mm/yy and the Input Mask as 99/99/00. Now something weird happens: After I enter the date as 30/08/04 (which is Aug. 30th/2004) and move on to the next object, the data changes automatically to 04/08/30! I don't know why that happens and how to prevent the MS Access from changing the data automatically. Could anyone give me some tips or suggestions?

    Thanks a ton!

  2. #2
    Join Date
    Jun 2004
    Posts
    92
    I got to say, I am not entirely sure why it is changing it...

    I got it to work and display the way you want it to by using: yy/mm/dd as the format for the field. Don't ask me why it works cause I don't know.

  3. #3
    Join Date
    Jun 2004
    Posts
    92
    I got to say, I am not entirely sure why it is changing it...

    I got it to work and display the way you want it to by using: yy/mm/dd as the format for the field. Don't ask me why it works cause I don't know.

  4. #4
    Join Date
    Jul 2004
    Posts
    5
    Thank you anyway...

  5. #5
    Join Date
    May 2004
    Posts
    159
    Could your regional settings be affecting how Access chooses to display the date?

  6. #6
    Join Date
    Dec 2004
    Posts
    2
    Try to use this.

    Property (Form)
    Control Source: =Format([Date Entry],"dd/mm/yy")

    Maybe this will work. But i can't guarantee

  7. #7
    Join Date
    Dec 2003
    Location
    Dallas, TX
    Posts
    1,004
    Hi urdoris,

    And "Welcome to the Forum"
    What country are you in? It seems there is something with your systems Regional Settings which is what Access is using. Go to ControlPanel and then RegionalSettings and see how your system is set up.

    have a nice one and hope you enjoy the Forum,
    BUD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •