I want to script Analysis Services to process a cube. I was hoping this would be possible through ADOMD, XMLA, or ADOMD.NET. But I researched this route and it doesn't seem to be possible. The only route is DTS which I find very odd (and difficult to work with).

AFAIK, the only way to do this is create a DTS job to process the cube and script the DTS package.

I've written a DTS package that does nothing but process the cube. When I run this through the Enterprise Manager GUI (right click the DTS package, execute) and it works perfectly every time with no errors.

I've written a C# program that does nothing but launch this DTS job. This always comes back with the error, "Invalid processing option". I can't imagine what this is referring to. I'm not setting any options; I just load the package and execute it. And I'm using the same code to load/execute the DTS package that I'm using for several other DTS packages and that works perfectly.

Any ideas?

The error log file that is generated when I run from the C# app is:

The execution of the following DTS Package failed:

Error Source: Analysis Services Processing Task
Error Description:Invalid processing option
Error code: 8004021D
\Error Help File:
Error Help Context ID:1000440

Package Name: Update Bounce Cube
Package Description: (null)
Package ID: {17AC55F3-D686-405B-9B2D-3CF5F62E83E0}
Package Version: {F94E846E-FB30-4190-A19C-802E0EA93EBE}
Package Execution Lineage: {8B567385-DB4A-4D72-9DEB-E97660452970}
Executed On: COMPU-B4619F953
Executed By: Administrator
Execution Started: 8/2/2004 2:03:49 PM
Execution Completed: 8/2/2004 2:03:49 PM
Total Execution Time: 0.157 seconds

Package Steps execution information:

Step 'DTSStep_DTSOlapProcess.Task_1' failed

Step Error Source: Analysis Services Processing Task
Step Error Description:Invalid processing option
Step Error code: 8004021D
Step Error Help File:
Step Error Help Context ID:1000440

Step Execution Started: 8/2/2004 2:03:49 PM
Step Execution Completed: 8/2/2004 2:03:49 PM
Total Step Execution Time: 0.031 seconds
Progress count in Step: 0
************************************************** **************************************************