Results 1 to 12 of 12
  1. #1
    Join Date
    Aug 2004
    Location
    India
    Posts
    13

    Unanswered: SQL5043N Error during db2start

    Hi ,

    I am getting the following error during db2start

    SQL5043N Support for one or more communications protocols failed
    to start successfully. However, core database manager
    functionality started successfully.


    Instance is db2inst1


    Following is there in the /etc/services file

    DB2_db2inst1 60000/tcp
    DB2_db2inst1_1 60001/tcp
    DB2_db2inst1_2 60002/tcp
    DB2_db2inst1_END 60003/tcp
    db2c_db2inst1 50000/tcp


    Following is there in the dbm cfg file

    TCP/IP Service name (SVCENAME) = DB2_db2inst1


    Following is the output of db2set -all command

    [i] DB2COMM=tcpip
    [g] DB2SYSTEM=aix2x4
    [g] DB2ADMINSERVER=db2das


    Also I am not able to catalog the databases through client configuration assistant

    any help regarding this would be greatly appreciated

    Thanks

    Falcon

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    Check you db2diag.log and/or the nfy file in sqllib/db2dump path

    Cheers
    sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Aug 2004
    Location
    India
    Posts
    13
    hI sathyaram ,

    The Ddb2diag.log doesnot have any information about it it says TCPIP support sucessfully started


    Regards

    Falcon

  4. #4
    Join Date
    Jun 2004
    Posts
    1
    Sorry for my english

    Have you right access permission on file /etc/services ??
    I remeber that this message represent a non valid access permission to
    some file, but i don't remeber the file

  5. #5
    Join Date
    Aug 2004
    Location
    India
    Posts
    13
    Hi g.dipierto

    I have read permission on /etc/services , I dont think you need to have write permission on /etc/services file Read permission only will do because my other instance are working fine with read permission on /etc/services file

    Regards

    Falcon

  6. #6
    Join Date
    Jan 2002
    Location
    USA
    Posts
    53
    Firewall, IP filter on your AIX?

    Best

  7. #7
    Join Date
    Sep 2003
    Posts
    85
    What are you specifying for the port # in the CA (used to be CCA) and what version of the client and UDB server?
    I'd think that you need to specify 50000
    as per db2c_db2inst1 50000/tcp ?

  8. #8
    Join Date
    Aug 2004
    Location
    India
    Posts
    13
    Hi rubystep I have tried out with 50000/tcp as well but it didnt work

    I am using V8 client and server

    Regards

    Falcon_down

  9. #9
    Join Date
    Aug 2003
    Posts
    4

    Cool Put the Port Number on the SVCENAME parameter

    Please, change the SVCENAME parameter to the Port Number, in this case 60000, with the command:

    update dbm cfg using SVCENAME 60000

    then:

    db2stop
    db2start

    Sometimes this is the solution.

    mrln.

  10. #10
    Join Date
    Aug 2004
    Location
    India
    Posts
    13
    Hi mrln
    Thanks for ur help

    But I tried that also , It didnot work

    Regards

    Falcon

  11. #11
    Join Date
    Aug 2004
    Posts
    1

    Have you recently installed a fixpack?

    I recently installed fixpack 5 and ran into the same problem. I realized I had not run the dasupdt utility after applying the fixpack as is noted in the readme.
    I had run the db2iupdt, but not the dasupdt. Once I ran that, I was able to successfully start the server.
    Don't know if this is your scenario but hopefully it will help.

  12. #12
    Join Date
    Jan 2004
    Location
    Tallahassee, FL, USA
    Posts
    96
    I asume , U R using DB2 V8 fp x
    add entry as below in /etc/services , then start the instance , that will work

    DB2_db2inst1 60000/tcp
    DB2_db2inst1_END 60003/tcp

    Let me know , if any questions.


    Thank You
    Lekharaju Ennam
    Certified Oracle8i & DB UDB DBA
    Florida A&M University

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •