Results 1 to 2 of 2
  1. #1
    Join Date
    May 2004
    Posts
    11

    Unanswered: Problems deleting records from table

    I am having some odd issues regarding deleting records from a table in a an Access 2000 database and can't seem to figure out a way around it.

    It is a standalone database on a Novell network, but only one user is accessing it (me).

    The error occurs when trying to delete records from a table and there are 3 different reations:

    1. I run a delete query for all records in the table - everything works fine.

    2. I run the same delete query but add criteria for a specific field (a date) - the progress bar fills up to about 75% then Access locks up completely and only a cntl-alt-del and 'end task' from the task manager will clear it.

    3. I delete records directly from the table manually - the amount differs, but at around 400 records or less, it works fine. At Over 400 (or so) I get the message "Couldn't Update; Currently Locked".

    Any ideas? Record locking is off, I am the only user in the database, the *.ldb file has been deleted, the table has been completely emptied and refilled - it still keeps happening.

    Anthony J. Kroes

  2. #2
    Join Date
    Oct 2003
    Location
    Canada
    Posts
    574
    My guess is it is a memory issue. For a workaround, you could try selecting the top 300 and running it several times. Have you tried using a recordset and deleting the lines one at a time? Have you compacted the database just before running the criteria based query? Are you deleting from a single table or is more than one table in the delete query?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •