Results 1 to 8 of 8
  1. #1
    Join Date
    Aug 2004
    Posts
    4

    Unanswered: informix error 11004

    I believe I pick up a virus a couple of days ago, now when I try to access my Factor database (AIX 4.3.3) through Microsoft Access I receive this error message.
    [INTERSOLV][ODBC Informix driver] Drivers SQL SetComectAttr failed. [INTERSOLV][ODBC Informix driver] Optional feature not implemented. [INTERSOLV][ODBC Informix driver][Informix] cannot Locate sqlexec service/tcp service in /etc/services.
    [INTERSOLV][ODBC Informix driver][Informix] Unkown error message 11004

    Can you please help?

  2. #2
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    Take a look if the entry actualy exists in the services file, and check the permisions on it.
    You might have to reinstall the driver.

  3. #3
    Join Date
    Aug 2004
    Posts
    4
    The file isn't there, but I've tried to completely reinstall the entire program and the disk is scratched and I cannot get the drive to read it. Do you know where I can find the driver?

  4. #4
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    if the services file is not there, restore it from the last good known backup
    /etc/services is the file that comes with the OS

  5. #5
    Join Date
    Aug 2004
    Posts
    4
    I tried that and it still doesn't work. I even loaded Informix Connect on another machine running a fresh version of Windows 2000 and I'm getting the same error. Is there a link I can go to and download that services file?

  6. #6
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    /etc/services keeps information about the ports, it is actually machine specific.
    You can edit that file and put in your own ports, like you have to do with Informix. I don't think that you can download the file.
    After you restore the file from somewhere, add the Informix port number like so

    sqlexec 1526/tcp

    the same entry has to exist in the services file on the windows machine
    from which you are trying to access the database.
    These settings also have to be in the setnet32.
    After you put in all of the right settings, test the connection.

  7. #7
    Join Date
    Aug 2004
    Posts
    4
    Where in the Setnet32 do I insert sqlexec 1526/tcp?

  8. #8
    Join Date
    Jan 2003
    Posts
    30

    Port in setnet 32

    Hi,

    You can put 1526 in the Service Name of the Server Information tab or

    in your WINDOWS-systemdir/system32/drivers/etc/services
    place
    sqlexec 1526/tcp and
    then place sqlexec in the Service Name of the Server Information tab.
    Make sure all other specs on your AIX machine are well filled in in the HOST information tab and the specs of your instance are entered allright in the Server Information tab and the Envirmonment variables tab:

    Regards
    Koen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •