Results 1 to 3 of 3
  1. #1
    Join Date
    May 2003
    Posts
    369

    Unanswered: TNS errors ORA-12560 on Windows 2000 and Oracle 9i

    I cannot connect to Oracle due to TNS errors, ORA-12560 TNS Protocol error. I am running Oracle 9i on Windows 2000 Advanced Server. I checked the listener status and Windows 2000 services but all are running and still get these TNS errors when I try to access the Oracle database via SQL*PLUS. Can anyone please help?

    $ lsnrctl status

    LSNRCTL for 32-bit Windows: Version 9.2.0.1.0 - Production on 24-AUG-2004 13:09:
    52

    Copyright 1991, 2002, Oracle Corporation. All rights reserved.

    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=win03)(P ORT=152
    1)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for 32-bit Windows: Version 9.2.0.1.0 - Produc
    tion
    Start Date 24-AUG-2004 13:08:07
    Uptime 0 days 0 hr. 1 min. 45 sec
    Trace Level off
    Security OFF
    SNMP OFF
    Listener Parameter File D:\ORACLE\R3D\920_32\network\admin\listener.ora
    Listener Log File D:\ORACLE\R3D\920_32\network\log\listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=win03)(P ORT=1521)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=win03)(P ORT=8080))(Presenta
    tion=HTTP)(Session=RAW))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=win03)(P ORT=2100))(Presenta
    tion=FTP)(Session=RAW))
    Services Summary...
    Service "MARKDEV" has 2 instance(s).
    Instance "MARKDEV", status UNKNOWN, has 1 handler(s) for this service...
    Instance "MARKDEV", status READY, has 1 handler(s) for this service...
    Service "MARKDEVXDB" has 1 instance(s).
    Instance "MARKDEV", status READY, has 1 handler(s) for this service...
    The command completed successfully

    Administrator@win03 ~
    $ tnsping MARKDEV

    TNS Ping Utility for 32-bit Windows: Version 9.2.0.1.0 - Production on 24-AUG-20
    04 13:10:03

    Copyright 1997 Oracle Corporation. All rights reserved.

    Used parameter files:
    D:\ORACLE\R3D\920_32\network\admin\sqlnet.ora


    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)
    (HOST = win03)(PORT = 1521))) (CONNECT_DATA = (SERVER = DEDICATED) (SER
    VICE_NAME = MARKDEV)))
    OK (90 msec)

    Administrator@win03 ~
    $ sqlplus /nolog

    SQL*Plus: Release 9.2.0.1.0 - Production on Tue Aug 24 13:10:12 2004

    Copyright 1982, 2002, Oracle Corporation. All rights reserved.

    SQL> connect / as sysdba
    ERROR:
    ORA-12560: TNSrotocol adapter error


    Thanks!
    Scott

  2. #2
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    What happens when you try with a username/password@markdev ???

    ie, c:\> sqlplus / nolog

    sql> connect sys/password@markdev as sysdba

    ??????

    You might also check your SQLNET.ORA file ... ensure that you are
    not using windows authentication ...
    ie ...

    SQLNET.AUTHENTICATION_SERVICES= (NONE)

    Gregg

  3. #3
    Join Date
    May 2003
    Posts
    369

    thanks

    That worked thanks again for your help. I am rusty on oracle having done ibm udb db2 and sql server the last 2 years need to get back into oracle.

    Scott

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •