Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2004
    Location
    Toronto, Canada
    Posts
    259

    Unanswered: Cant delete records

    I cant seem to delete records! I have a query which produces a set of results. I want to delete all those results from the query; i have tried right clicking, and the "delete record" thing is greyed out.

    I also tried a delete query and it says, "Could not delete specified tables."

    wat should i do?

  2. #2
    Join Date
    Jul 2004
    Posts
    125
    If the recordset is composed of two or more sources (tables), the cascading link must be a primary key or a uniquely indexed value. Also this field may have to be part of the SQL statement (the query grid) under certain conditions. For example: unique -> many, unique -many . . . etc. In a many <-> to many relationship the selection cannot be resolved by the database engine, otherwise you would end up deleting records you do not wish to delete. Redefine your indexes of your linked fields to meet this criteria.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •