Results 1 to 10 of 10
  1. #1
    Join Date
    Aug 2004
    Posts
    20

    Exclamation Unanswered: Apache error log file keeps growing

    I am running Windows XP Service Pack 2 and I'm trying to install Oracle 9i, Release 2 (9.2.0.1.0). After everything is installed, the Apache error_log file keeps getting bigger, whether Oracle is opened or not, eventually filling up the entire harddisk. I've had to deinstall Oracle twice, so far. I've seen lots of people in forums with this same problem, but nobody seems to have an answer. The only thing I've seen resembling an answer is to make the error_log file 'read-only,' which does not fix the root of the problem. Certainly someone must know the cause of this problem, but I sure can't find an answer.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    > but I sure can't find an answer.
    When I see errors in my Apache error logfile, I fix the problem so Apache stops complaining.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jul 2003
    Posts
    2,296
    turn off apache?
    that works for me
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Alternatively modify httpd.conf so the error_log file resides in /dev/null.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Jan 2004
    Location
    Germantown, MD
    Posts
    34
    What are the errors you are getting?
    "The world is a dangerous place, not because of those who do evil, but because of those who look on and do nothing. "
    - Albert Einstein

  6. #6
    Join Date
    Aug 2004
    Posts
    20
    Here's the deal, I installed Oracle for the 3rd time this morning to see if I could get it to work. Making the error_log file 'read-only' does nothing, and when I try to stop Apache, I get this error:

    syntax error on line 92 of C:\oracle\ora92\sqlplus\admin\isqlplus.conf
    failed FastCGI application accept mutex

    and this is what's on line 92 of the conf file:
    <IfModule mod_fastcgi.c>
    FastCgiServer C:\oracle\ora92\bin\isqlplus -port 8228 -initial-env iSQLPlusNumberOfThreads=20 -initial-env iSQLPlusTimeOutInterval=30 -initial-env iSQLPlusLogLevel=off -initial-env iSQLPlusAllowUserEntMap=none -idle-timeout 3600
    </IfModule>

    I can't find out what errors are being recorded in the error_log file, because by the time I get Oracle deinstalled and am able to access the error_log file, it has grown to 7 GB and will not open.

    I need this program for 2 classes that I am taking right now, and I really need to get it working ASAP.

    Thanks a lot for any help

  7. #7
    Join Date
    Jul 2003
    Posts
    2,296
    why don't you select CUSTOM INSTALL and de-select the Apache install?
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  8. #8
    Join Date
    Aug 2004
    Posts
    20
    I tried that, and it says Apache is a required component and cannot be deselected.

  9. #9
    Join Date
    Oct 2003
    Posts
    26
    Apache is only required if you need to load Oracle Management Server and the Enterprise Management Web Server. If you use a CUSTOM install and uncheck those boxes (under Enterprise Management Products) you should be able to load Oracle w/o Apache.

    HTH

    John

  10. #10
    Join Date
    Aug 2004
    Posts
    20
    Thanks for the help, I got it fixed last night. I had to comment out the line:

    include "\oracle\ora92\sqlplus\admin\isqlplus.conf"

    in the
    C:\oracle\ora92\Apache\Apache\conf\oracle_apache.c onf
    file.

    Sounds like doing the custom install would have worked too, but it's fixed either way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •