Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2004
    Posts
    6

    Unanswered: Problem referencing field in query from tab controlled form

    I have a Tab Controlled form, which I have copied several different forms onto their corresponding tab pages. One of the fields on one of the forms calls an append query. The criteria for the append query is equal to a field on the tab page that opens the query.

    The strange thing is that before I copied the form onto the tab controlled form, this query worked perfectly. Once I copied the form onto the tab controlled form and changed the criteria in the query to the new form information, it stopped working.

    The criteria to reference the field in the original form is:
    [Forms]![frmAttendanceList]![CycleID]

    The criteria to reference the field in the new Tab Control Form is:
    [Forms]![frmStartup]![Attendance List]![CycleID]

    I've tried this also without the [Attendance List] part (which is the page name) as well without success. And with just [CycleID].

    Does anyone have any ideas?

  2. #2
    Join Date
    Aug 2004
    Posts
    13
    If I understand you correctly, you pasted a form inside the page. Thus you have to refer to the name of the form you pasted in the page after the page name. IE [forms]![form name]![Page name]![subform name]![control name].

    I have not done it in a couple of years, back during office 97. But I believe it is how I accomplished it.

  3. #3
    Join Date
    Aug 2004
    Posts
    6
    Ah - my problem was that I hadn't realized it was actually a subform. Doh! So, the answer is close to what you suggested, minus the Page Name:

    [forms]![form name]![subform name]![control name]

    Thanks for your insight!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •