Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2004

    Exclamation Unanswered: How to repair Access 97 record corruption


    We've got an old Access 97 database at work.

    The form layout isn't pretty, but it does it's job. Occasionally, we experience record corruption where Access tells us "The Microsoft Jet database engine stopped the process because you and another user are attempting to change the same data at the same time."

    I've figured out that this error is generated when a user opens two different forms and works on the same record with both forms. Apparently, Access considers each form a "user". Now that I've determined the cause of the problem, we will tweak the form design so that all changes can be made on one form, reducing the likelihood that a user will use two forms at the same time.

    Our only method of dealing with the problem in the past has been to delete the record. I prefer to find a method to repair the record, but have yet to figure out how.

    My question:
    How can I edit the record to correct the problem, once it has occurred?

    Even after closing down Access and reloading the database exclusively, the error is displayed whenever that record is touched...even in table view.

    Thanks in advance,


  2. #2
    Join Date
    Feb 2004
    Chicago, IL
    I have not seen that error before, even though I have run into the situation where more than one user is trying to modify one record. I am wondering, what kind of record locking do you have set up for your database? (Tools, Options, Advanced Tab)

    I have always left it on the default setting No Locks.

  3. #3
    Join Date
    Jun 2004
    Arizona, USA
    "Lisa, in this house, we obey the laws of thermodynamics!" - Homer Simpson
    "I have my standards. They may be low, but I have them!" - Bette Middler
    "It's a book about a Spanish guy named Manual. You should read it." - Dilbert

  4. #4
    Join Date
    Aug 2004
    Thanks loquin, I'm going through those posts now but am not finding anything related.

    The interesting thing behavior is that the database is still usable, it's just that one record that causes a problem. I've tried repair & compact, but that doesn't help. I've also tried importing all objects into a blank database, but then the exact same error occurs when trying to import the table with the problem record.

    Additionaly, I've noticed that there is a value of #error in one of the fields of the "corrupt record".


  5. #5
    Join Date
    Aug 2004
    This has happened to me a few times. I found that if I create a new database and import one section at a time to narrow down where there error is.
    IE table, query, report, forms etc

    Once you find the corrupted type of entity you will have to manually recreate it.

  6. #6
    Join Date
    Aug 2004


    I accidentally double-posted my original question somehow. Anyway, I thought I'd copy the solution here for future reference to help others with the same problem. Credit should go to registered user andybriggs for the solution. Andy's reply is below:

    I have a feeling your problem is caused by something else - namely, a Memo field that has lost its pointer to its parent record. This used to happen regularly with Access 97 and generates the exact error you are getting.

    Check your data to see if you have any Memo fields in the table(s) behind your form. If you have, then that is almost certainly the problem.
    Good news - Microsoft released a fix for this which is incorporated in their compact/repair utility called JetComp.exe

    I am not sure if you can still download this from MS but if not I am sure you can Google on it. You want the version for Jet 3.0 / 3.5.

    When you compact the database using this utility you will find that the problem goes away. Usually it stays fixed, but occasionally you may have to repeat the process.

    I hope this helps and I'd be interested in knowing if I was right!!
    Andy Briggs
    Elmhurst Solutions Limited
    Database Development and Consultancy
    Here's the link I found over on Microsoft's web site:;en-us;273956

    If you scroll down, you will be able to downloade the utility, JETCOMP.exe (actually, you download an archive called JetCU40.exe).

    Next, unpack the self-extracting archive file and run JETCOMP.exe. It asks for the source database and a destination database (it makes a copy, rather than overwrite the existing database).

    Since we are using Access '97, we have to make sure we select "Destination is 3.x database format", as the 3.x format is for Access 97, the 4.x format is for Access 2000.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts