Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2002
    Posts
    162

    Unanswered: users and logins failed to restore?

    HI guys,

    I just restored a database on a new server with a backup(complete backup stored in backup device) from another database on another server using the "with move" option. In fact here was my process:


    Alter database ngauge SET SINGLE_USER WITH ROLLBACK IMMEDIATE

    restore database ngauge
    from disk = 'C:\Program Files\Microsoft SQL Server\MSSQL\BACKUP\ngauge1.BAK'
    with move 'NGAUGE' to 'C:\Program Files\Microsoft SQL Server\MSSQL\Data\ngauge_Data.MDF',
    move 'NGAUGE_Log' to 'C:\Program Files\Microsoft SQL Server\MSSQL\Data\ngauge_Log.LDF'

    Alter database ngauge SET READ_WRITE


    it worked.

    But it did not move the 98 or so users/logins...from the source database
    what is going on??? what am I doing wrong??!!


    Please help!

    'W

  2. #2
    Join Date
    Jan 2004
    Location
    In a large office with bad lighting
    Posts
    1,040

    orphaned users?!

    did you port your users in the old master database to the master database on the new server? if not, you have created orphaned users in the database that you restored to the new server. Check this article for information:

    http://vyaskn.tripod.com/troubleshoo...phan_users.htm

    Then, you can check several sql server sites for scripts that will help.

    Tom

  3. #3
    Join Date
    Mar 2002
    Posts
    162
    Thanks a lot! I fixed it. It was Def. an Orphaned users problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •