Results 1 to 13 of 13
  1. #1
    Join Date
    Mar 2004
    Location
    Germany
    Posts
    18

    Unanswered: I can't start Informix

    Hello,

    I installed IDS and Client SDK on a Linux machine. After that I have define correctly the environment variables INFORMIXDIR, INFORMIXSERVER, LD_LIBRARY_PATH, PATH. The files onconfig and sqlhosts are also Ok (I think so).

    But when I want to initialize a database using the command oninit -vi, everything runs succesfully till the line:

    Initializing ASF

    at this point I get the shell prompt again and the db isn't started. How can I do?

    Best Regards

    Alfredo

  2. #2
    Join Date
    Mar 2004
    Location
    Netherlands
    Posts
    183
    Hi Alfredo,

    ASF problems normally occur when you have setup the wrong communication settings. The most probable reason is the sqlhost file or the NETTYPE onconfig parameter. Either they don't match or you have specified an incorrect protocol. A common problem is that people set-up TLI (with ontlitcp) while Linux is using sockets (onsoctcp). If this doesn't help please post your sqlhosts file and your onconfig.

    Hope this helps,

    Rob Prop

  3. #3
    Join Date
    Feb 2004
    Posts
    32
    post the output of
    oninit -v
    sqlhosts file entries.
    /etc/services file entries.

    -Abraham

  4. #4
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi Alfredo,

    If you SO is Linux, please do upgrade of glibc.

    Gustavo.

  5. #5
    Join Date
    Mar 2004
    Location
    Germany
    Posts
    18

    onconfig, sqlhosts, services, oninit -v

    Hello,

    many thanks to all. I post the files you suggest.

    Hi Gurey. Yes, my SO is Linux and my glibc is the 2.2.5-164. Should I actualize it?

    Best Regards

    Alfredo
    Attached Files Attached Files

  6. #6
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Yes, Up to 2.2.5-165 or highest.

    Gustavo.

  7. #7
    Join Date
    Jun 2004
    Location
    Madrid, Spain
    Posts
    47
    Hi,

    From the files you sent, it seems that you've missed the DBSERVERNAME parameter:

    - Double check that the IFX server name you're using in the sqlhosts file exists in the onconfig file (DBSERVERNAME or DBSERVERALIAS).
    - Double check that the host name you're using exists in /etc/hosts.
    - I've seen that the service name you're using exists in /etc/services. Double check it anyway.

    And next time pls. send the last lines on the online.log file (or the file you've used according to MSGFILE parameter).

    Hope it helps.
    José Luis Matute.

    Regards from Spain.

  8. #8
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,
    The onconfig.txt file is the default. You should do a copy of the onconfig.std and customizing that copy, should change the values of DBSERVERNAME, DBSERVERALIAS, NUMAIOVP, etc.
    I agree with Matute.

    Gustavo.

  9. #9
    Join Date
    Mar 2004
    Location
    Germany
    Posts
    18

    Problem is always there

    Hello,

    i tested everything you say and unfortunately the problem continues. I check all the values again and the problem is still there. The last lines from the file online.log are:
    --------------------------
    Mon Sep 6 14:37:39 2004

    14:37:39 Event alarms enabled. ALARMPROG = '/opt/informix/etc/log_full.sh'
    14:37:39 Assert Failed: net_init.c, line 319, thread 1, errno=13, error in creating /INFORMIXTMP.
    14:37:39 Informix Dynamic Server Version 9.30.UC2E3
    14:37:39 Who: Session(0, @, 0, 0)
    Thread(1, main_thread, 0, 1)
    File: neterrb.c Line: 658
    14:37:39 stack trace for pid 1131 written to /tmp/af.3e95a13
    14:37:39 See Also: /tmp/af.3e95a13, shmem.3e95a13.0
    14:37:40 neterrb.c, line 658, thread 1, proc id 1131, net_init.c, line 319, thread 1, errno=13, error in creating /INFORMIXTMP..
    14:37:41 PANIC: Attempting to bring system down
    --------------------------
    The system date on the server is not correct, should be Thu Sep 9, but is not important.

    Please help !!! What can I do now?

    Best Regards

    Alfredo

  10. #10
    Join Date
    Jun 2004
    Location
    Madrid, Spain
    Posts
    47
    Hi,

    From the system error (13) it seems it's trying to create/access some files during initialization, and the permission isn't right. It could also be a problem during installation: as far as the oninit process sould have permissions 6755 (notice the set-owner-id and the set-group-id bits) and be owned by root, there should be no problem creating any file. Have you branded the product, runing the RUN_AS_ROOT.xx script? Also check the informix product directories permissions and the chunk persmissions.

    If the problem continues and the log states about an af file, send the first lines.

    Another point: have you set the ONCONFIG env. variable (it should be your onconfig file name, without the path).

    Keep trying,
    José Luis Matute.

    Regards from Spain.

  11. #11
    Join Date
    Mar 2004
    Location
    Germany
    Posts
    18

    Now problem with chunk

    Hello,

    Thank you very much Matute. I change the owner and rights for oninit and the command oninit -iv comes through. Now I get a problem with the chunk. Excuse me, but I'm not Linux Administrator. I have define as ROOTPATH the path /dev/online_root and this is the chunk for the root dbspace, I think. I get the following error messages:

    oninit: Cannot open chunk '/dev/online_root'. errno = 2
    oninit: Fatal error in shared memory initialization

    What should be /dev/online_root? A directory or a file? Which permission should it have? What should I do in a Linux level to create this chunk? Please, if you can, tell me exactly the required commands to do this.

    Best Regards

    Alfredo

    Pdta: I see you come from Spain. I speek also español, I live in Germany but I come from Southamerica.

  12. #12
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    make sure the chunk in user group informix and the permisions are correct

    chown informix:informix chunk_name
    and the permision is 660

    chmod 660 chunk_name

    Cheers

    Artem

  13. #13
    Join Date
    Mar 2004
    Location
    Germany
    Posts
    18

    Now works

    Hello,

    many thanks for all your tips. My Database Server runs now without problem !!!

    Best Regards

    Alfredo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •