Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2004
    Posts
    3

    Unanswered: MYSql on WinXP starting problem

    I'am new user of mysql, and have some problem.
    I installed mysql without problem, but can't start it. It doesn't metter if I start is as a service or in command prompt, when I type "mysql" in promp after, the message is :
    ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)

    Even with winMysqladmin, never mind if service is started or not, there is no server info.

    What can I do?

  2. #2
    Join Date
    Mar 2004
    Posts
    480
    try this or something similar depending on where mysql is installed on your system:

    Code:
    c:\mysql\bin\mysql -uroot
    IF that works for you then you are on your way. I'm not sure how to install it as a service under windows or what file to edit so you don't have to type the whole path. If you don't use the -uroot though you will run into the problem you have stated as I believe you are starting the client as the current user (i.e. whatever account you are logged into your computer as) which of course won't have permissions to the mysql system until you grant them.

  3. #3
    Join Date
    Sep 2004
    Posts
    3
    I'am starting with a user who have all permissions, so this is not the answer to my problem.
    The problem is that when I type "mysqld-nt" in command prompt server doesn't start, so I can't connect to it.
    I don't know how to make it start.

  4. #4
    Join Date
    Sep 2003
    Location
    United States
    Posts
    65
    Provided Answers: 1
    first check your my.ini file for proper configurations, for learning purpose there are very few configuration settings that u have to make in the my.ini file which is located in the root of WINDOWS folder.

    Soon after installation run winmysqladmin.exe from the installationfolder\mysql-4.0.0\bin it will take the initial username(type some username and rememeber it).

    This will setup a service which will by defaul start and stop along with OS

    Or else you can run the mysqld-nt.exe from command prompt that will also do.

    Now you should be able to connect without any issue. username root has no password by default(i'm using mysql 5.0.0 alpha). So things may differ by a bit.
    >>
    >> Learn PHP/MySQL for free https://www.youtube.com/watch?v=mpQts3ezPVg
    >> Free Web Hosting with PHP, MySQL, Website Builder : http://www.000webhost.com/862861.html

  5. #5
    Join Date
    Sep 2004
    Posts
    3
    I did exactly what you said!
    Even before I asked here, but the error message is still there. When i start winmysqladmin there is no server info.

    Have you any other ideas?

  6. #6
    Join Date
    Dec 2004
    Posts
    2
    I don't know if this is a bit late.
    But if you are still facing the problem, I had the same problem as you do.
    I installed myqsl 4.1.7 successfully but cannot get it running. I don't remember what the error was but i think it was something like what you had.

    So what i did after uninstall and re-install a few times and still had the same
    problem was to install mysql on a different directory than the default one.
    The default directory was c:\program files\mysql\mysql server 4.1\,
    so during installation i changed this to c:\mysql\ and it worked fine after that.

    Hope this help you and those who faced similar problem.

  7. #7
    Join Date
    Mar 2004
    Posts
    370

    Why mysqld-nt?

    Hi,
    try this: first of all "mysqld --install_service" or something like this! you can find this by typing "mysqld --help".This will install your mysqld(nt) as a windows service which you can edit it later and make it autostart.
    So it is enough to enter "net start mysql" and your service will be run.
    -let me know if it is solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •