Hi, i've this problem with crystal reports. With two related tables, named TipoAct and Actividades, i need to obtain a report like this:

TipoAct----NombreAct------CantidadRealizadaDeTipo---MinutosTot

1-----------SOPORTE----------------2--------------------30

2-----------APOYO SOFT------------1---------------------20

3-----------APOYO HARD------------0----------------------0

4-----------OTROS------------------3---------------------15

For the kind of activitie 1 exists 2 activities that sum 30 minutes, for the kind 2, 1 activitie to 20 minutes, etc. This is the whole table, but if i set the selection formula to a data range like this:

{Actividades.dFechaAct}>={?pdFechaIni} and {Actividades.dFechaAct}<={?pdFechaFin}

the filter works but the report fails in the presentation. For example, suppose that the 3 activities of the kind OTHERS don´t belong to the range of dates, the report prints this:

TipoAct----NombreAct------CantidadRealizadaDeTipo---MinutosTot

1-----------SOPORTE----------------2--------------------30

2-----------APOYO SOFT------------1---------------------20

3-----------APOYO HARD------------0----------------------0

when it would be:

TipoAct----NombreAct------CantidadRealizadaDeTipo---MinutosTot

1-----------SOPORTE----------------2--------------------30

2-----------APOYO SOFT------------1---------------------20

3-----------APOYO HARD------------0----------------------0

4-----------OTROS-----------------0----------------------0

because there's no activitie of kind 4 in the range so the number of activities for the kind and the minutes used are equal 0, but must appear the row in the report showing these zeros. What i'm doing wrong?? The filter? the links??. The table "TipoAct" is linked with a LEFT OUTER JOIN kind link with the "Actividades" table. When there isn't a filter it works, even there's no activitie for a specific kind, but when i set a filter doesn't work. Thanks for the help.