Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2004

    Unanswered: Schema Modification problems...

    I have modify the schema which is already registered,

    Initial workaround
    1. Registered the schema.
    2. Created the table.
    3. Duplicated the table to a temporary table.
    4. Unregistered the Schema.
    5. Dropped the main table.

    The interesting thing i noticed is, the main table which is associated with the schema is not working and it contains some errors.
    The duplicated temporary table is working fine and is able to accept any sort of entries with the independent of schema.

    Later on i re registered the schema and created the table, I tried to copy the data from the duplicated temp. table to the original table created.
    I found the error called: "Schema and element donot match"

    FYI: I have tried with the same schema and withe the same table configurations what i had initially.

    Why this error occurs...
    Can anyone suggest me your ideas for this problem ?

    Thank you in advance....

  2. #2
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    I've worked with Oracle for 8+ years.
    I have NO idea what you are talking about.
    Rather than explain in English what you think you are doing,
    why don't you post a cut & paste of EXACTLY what you did & how the system responded?
    What OS & OS version?
    What Oracle version to at least 4 decimal places?
    >Why this error occurs
    You did something wrong
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jul 2003
    man that is confusing.

    how do you REGISTER a schema? This is a new concept to me.

    wait ... are you referring to an XML schema??
    if so, why wouldn't you state such a thing to begin with??
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  4. #4
    Join Date
    Sep 2004

    Clear Description of the problem...

    I have registered the xmlschema and created an xmltype column table which is associated to that schema. I uploaded some documents to it. Now the issue is i have to modify the schema, now for doing this, i have duplicated the table by using create and select combination syntax. I have dropped the original table and unregisterd the xmlschema. I have registered the same schema and created the table as of before. To getback the data from duplicated table to original table i have used combination of insert and select statements. While inserting the data, i am getting the error called

    ORA-19007 - Schema and element donot match.

    ??????? - How to resolve this issue.

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts