Dear Anyone,

Our OLAP users reported inconsistencies with their reports. To better describe the problem please refer below:

Item 1 -- 2
Item 2 -- 5
Item 3 -- 3
Item 4 -- 1
Total -- 15

As you can see, the totals does not match the details of the report. The measure involved is a physical measure.

We noticed the following error in the application event log:

Error during lazy aggregation of partition Broadcast_Response_2004_07 in cube Broadcast_Response:

Error during lazy aggregation of partition Broadcast_Response_2004_06 in cube Broadcast_Response:

Error during lazy aggregation of partition Broadcast_Response_2004_08 in cube Broadcast_Response:



The errors above has led us to the following knowledge base articles:

http://support.microsoft.com/defaul...kb;EN-US;325289

http://support.microsoft.com/defaul...kb;en-us;259677

http://support.microsoft.com/defaul...kb;en-us;820358



Our OLAP Application Setup
Cubes: 2
Cube Partitions: Monthly
Average Number of Records per Partition: 23M
Active Partitions: 8

Distinct Count: Yes

Virtual Cubes: 1
Changing Dimension: 2

Operation: Incremental Update of All Partitions Everyday
Incremental Process of Cubes Every Day

BI Accelerator: Yes

Our main concern is that the knowledge base articles instructs us to re-aggregate the entire cube in order for us to work around the problem. The problem is we incrementally update our changing Dimensions everyday. To add to this, we measured how long it takes to full re-aggregate one partition it took more than 45 minutes to finish one. Totalling all the time it takes for our process to finish, the time involved in the suggested work around would be impractical for us.

Is there another way to resolve these problems?

If we remove all user designed aggregations from all our cubes, will we still end up with the same problems?

I hope you give us some insights and suggestions with this problem.



Thank You
Joseph Ollero


P.S.