Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2003
    Posts
    5

    Unanswered: Decimal symbol is "," (comma) instead of "." (DB2 Connect problem)

    Hi,

    SW : DB2 Connect version 7 FixPack 12

    After upgrading to the above version I started having this problem (only on one of our servers - others works fine) -

    When I select data from a decimal number the decimal symbol is "," instead of "."

    I have checked that global settings is US and that decimal symbol is set to "."

    Can someone point me to where DB2 Connect reads what the decimal point is set to - or give a hint to where this can be changed. There is nothing in the db2cli.ini file that indicates that the decimal point should be ","

    Thanks

    Regards
    Peter

  2. #2
    Join Date
    Jun 2004
    Posts
    2
    I experience the same problem after making the move from 7(FP12) to 8.1. I din't find a solution and deinstalled version 8.1 and reinstalled version 7. Now guess what? The problem still persists

    Any help is greatly appreciated
    Greg, Switzerland

  3. #3
    Join Date
    Jul 2003
    Posts
    5

    Decimal symbol is "," (Comma) instead of "." (DB2 Connect problem)

    If anyone has any interest in this I found the reason for the problem.

    Aparantly DB2 Connect V7.1 FP12 uses the setting in
    control panel --> Regional settings --> On the first pane there is a "Set Default" buttom.

    The default needs to be English (US) (or probably another country that uses "." as the decimal separator.

    Don't know whether this is a bug or not.

    Regards
    Peter

  4. #4
    Join Date
    Jun 2004
    Posts
    2
    Hi Peter

    Thank you for your feedback, which helped me to solve the problem.
    I'm using Windows 2000 and there are two settings for the regional options, one for the current user and one for system. Both of them were set to German (Switzerland). This locale defines '.' as the decimal symbol but I've still got ',' in my db results, so this seems to be a bug. After having changed the system locale to English (United States) I now get '.' again as desired.

    Thank you again for your valuable help.

    Greg, Switzerland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •