Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2004
    Erlangen, Germany

    Cool Unanswered: Informix on a Sun Solaris Server

    Hello together!
    I have a SunOS 5.5.1 with an installed Informix-Environment. I also have the root password...
    I want to gather some information about this system.
    - Where are the database files stored
    - Why can't I reach the database over ODBC
    - How can I access the databases
    - How can I open the ODBC Connection

    Usually this should not be a problem, but this Informix Database is part of a CMS System installed by Lucent. I think they modified the Informix Installation to fit their needs.

    When I start dbaccess and want to select a database I only find an empty list. But I know that the database is running
    A ps -A shows me several sqlexec processes running

    The directory /opt/informix/etc contains the sqlhosts file:
    demo_on onipcshm        on_hostname     on_servername
    demo_se seipcpip        se_hostname     sqlexec
    cms_se  seipcpip        r342b8bg        sqlexec
    I hope someone can help me...
    Thanks in advance

  2. #2
    Join Date
    Sep 2004
    Erlangen, Germany
    I have another question about the sqlhosts file...
    In the above posting there is my sqlhosts file. The database cms_se can only be reached via unnamed pipes.
    Is it possible to activate tcp/ip and at the same time the communication over unnamed pipes?

    This is a production system. Because of this I must be careful with my changes.
    Would be cool if someone could help me with this!

  3. #3
    Join Date
    Jun 2004
    Madrid, Spain

    I'm impressed that you're running Standard Engine on Solaris 2.5. It's kind of an old system! It sholudn't be a bad system anyway. BTW: Lucent used to be a great Informix programmers nest, at least in Spain... and every Informix installation must be customized. It's not their fault.

    Let's try to remember... it's been nearly 8 years I saw SE for the last time.

    About the databases: I'm thinking about the DBPATH env. variable, and don't exactly remember if it should point to the database location. If you don't know it, you could try a 'find / -name *.dat -print' or 'find / -name *.idx -print' command (as root), so it will tell you where the database data and indexes files are, and point DBPATH to it. Sorry I can't remember the file names...

    About the connectionIf you're ruinning SE v.5 you'll need Informix-Star to get the ODBC connectivity from other systems. If you're using Informx-SE v.7 it could/should be integrated. Look for the sqlexecd process, and if not found, look for it under $INFORMIXDIR. Launch it with the proper settings for DBPATH, INFORMIXDIR, PATH, etc. BTW: Does your application have an initialization script, an special user, or something like it? If so, you could catch the env. vars. settings from it... and look for your machine notes ($INFORMIXDIR/release). They could/should state someting about the possibilities for tcp protocol.

    Sorry I can't remember just now any more tips. Keep asking, anyway, and I could look for any more documentation.

    Hope it helps.
    José Luis Matute.

    Regards from Spain.

  4. #4
    Join Date
    Sep 2004
    Erlangen, Germany
    Wow! That helped a lot! Thank you VERY much!

    These days I learned a lot about Solaris and Informix...
    Now what I have done after reading your Mini-Tutorial:
    I setup all the Environment variables needed by Informix:
    - DBPATH (at least I found the filez)

    I also know now that I'm running Informix-SQL Version 7.22.UC2 which is not as old as I though ;-) (check_version told my about 2.xx)
    Oh! And a uname -a told me that I run the following:
    SunOS r12a2cde 5.7 GENERIC usw...
    That means 2.5.7 aka Solaris 7?? Should be correct...

    After inserting $INFORMIXDIR/bin into my path I could run dbaccess as root und connect the the Server for the first time. The problem was that I could not see the databases.
    I checked the DBPATH and the read/write privileges but everything is okay... But this problem cannot be very complex. I also started playing around the settings in the sqlhosts.

    After starting the server and reading the logs the following error occurs.
    daemon err = -25592 Communication service not supported by network driver
    or this one:
    daemon err = -25507 The specified service name or protocol is unknown.
    I think that could have to do with this Informix-Star... In both cases the service entry was made in /etc/services
    I tried 1526/tcp turbo and 1400/tcp nettype and 1399/tcp sqlexec
    None of them worked. I think I only must know what protocol type I have to use and the database works over ODBC.
    This would be the killer-solution. I would be content if I could see and select the databases with dbaccess...

    Would be cool, if you guys could help me again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts