Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2004
    Posts
    5

    Unanswered: Problem creating database ,, please help

    Hi there,
    I have installed oracle 9i . I am able to you use it , login to sql prompt, do all the commands norman but when I log to the sql workshop and try to create a database , I get the following error:

    Connected.
    create database AIS
    *
    ERROR at line 1:
    ORA-01501: CREATE DATABASE failed
    ORA-01100: database already mounted


    I am connected as SYS , I tried also as system but no luck

  2. #2
    Join Date
    Feb 2004
    Location
    Dublin, Ireland
    Posts
    212
    I think it's because DB with the same name already
    exists. Try another name.

  3. #3
    Join Date
    Jan 2004
    Location
    India
    Posts
    113
    The problem here is here I think u have already created the default database and after logging into that u give another create database statement which is wrong.

    Ideally it should be like this u create an Oracle instance using the oradim utility. After creating the instance with proper passwd for the sys user.
    Log into sql prompt as sys it will say something like connected to an idle instance. Then issue the create database statement...

    Good luck
    Kaushik

  4. #4
    Join Date
    Nov 2002
    Posts
    833
    on windows
    create a service first with your new SID
    :\> oradim -new -sid <your_sid> -intpwd <a_password>
    set ORACLE_SID=<your_sid>
    then connect / as sysdba
    connected to an idle instance should show up
    startup nomount pfile=
    create database ...

  5. #5
    Join Date
    Sep 2004
    Posts
    5
    thanks all, as you said the database existed there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •