Results 1 to 3 of 3
  1. #1
    Join Date
    May 2004
    Posts
    7

    Exclamation Unanswered: Restore Database problem - LOADING forever

    I had to restore a database late this afternoon. I have the database set to FULL recovery. Database backups are performed nightly and transaction log backups are performed every other hour. I decided to perform a point-in-time restore. When I restored this way everything seems to go ok and it finishes. Then the database is grayed and says "Loading". Although I tried 4 separate times, one time allowing over an hour, the grayed out database and "Loading" never goes away.

    Freaking out I deleted the "Loading" database (didn't delete logs and backup files) and tried a manual restore from the previous night's backup file. It attached and restored properly and was ready to go in 2 minutes.

    Of course I wanted to get the transaction log files restored too, since it had work from earlier today. So I tried another restore via point-in-time and got the same old messages. Currently, the database is running with the previous night's backup restored but the users aren't too keen on having to do 5 hours worth of work to catch up to the previous transaction log backup come Monday morning.

    Any suggestions?

    Thanks,
    JB

  2. #2
    Join Date
    Oct 2001
    Location
    England
    Posts
    426
    How are you doing the restore? And why do you want to restore to a point in time?

    Do it via query analyser with standby - this will enable you to look at the database between restores.

    Do the full restore - look at it.

    Now do the tr logs in turn - checking the database between each one.
    Now you can do the last one with the point in time recovery.

    If that fails then go back and redo up to the last one that restored successfully. At least you will lose at the most 2 hours.

  3. #3
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    The poster probably did not click on Refresh menu item on Databases folder in EM.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •