Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2004
    Location
    Far away from heaven
    Posts
    194

    Unanswered: Attach database fails

    Folks, i had a database with data and log file on seperate disks. After reboot, i've lost the log file; now i am trying to attache the data file using EM and QA, i get the following error; plz guide:

    sp_attach_single_file_db 'production', 'd:\production_data.mdf'

    Server: Msg 1813, Level 16, State 2, Line 1
    Could not open new database 'production'. CREATE DATABASE is aborted.
    Device activation error. The physical file name 'D:\production_log.LDF' may be incorrect.


    Howdy!
    Last edited by thebeginner; 09-20-04 at 13:06.

  2. #2
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    try this...creat an empty database with that name...then detach it, and then try you attach
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  3. #3
    Join Date
    Jun 2004
    Location
    Far away from heaven
    Posts
    194
    Hi Brett, same error. If i give the logfile for newly created database(as u suggested) i get the error can not associate files from different databases.



    Howdy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •