Hi ..

Im trying to get merge replication working over the internet.

I created the publication and subscriptions without any problem.

I started the merge agent without any problem and the initial snapshot was generated on the subscriber. But then not longer after that the merge agent failed with the error message 'Subscription to publication is invalid'. Anyone have any idea on this?

I've tried looking for a solution for this problem without any luck.

Im registering the subscriber on the publisher using an IP address and i've created a lmhosts file on the publisher to do the name resolution.

I ran sp_helpserver on both the publisher and the subscriber and indeed the subscriber name on the publisher is an IP address and the subscriber name on the subscriber is the computer name of the subscriber. Would this be the problem knowing that ive created a lmhosts file to do the name resolution? And if so, is there any way i can solve this because i cant think of anyway to register the subscriber on the publisher without using an IP address.

Regards,
- Adrian -