Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2004
    Posts
    3

    Unanswered: Cron is not outputting log files...

    Newbie to the site here and semi-newbie with Linux. I have a question regarding CRON. I currently have a Windows 2000 system with CYGWIN installed. CRON is working on the system and is able to run basic commands and Shell Scripts. However, I have a semi-large Bash Shell Script that runs several TCL/TK scripts and Windows applications. When I run the Shell Script with CRON I am failing to see any of the output files created by my TCL scripts and Windows Applications. When I run the Shell Script manually from CYGWIN it runs perfect.

    Here is the line I have in my CRONTAB:

    0 11 * * * . /tmp/NiteBld.sh

    After reading other sites, it looks like I might have a problem with the environment variables CRON is using, which differ to what CYGWIN might have setup. Is there a way I can mirror my normal environment variables to CRON?

    Also, I have read that I might be running into a file permissions problem. I have CHMOD all of the folders that will have output logs written to, but with no luck.

    Please let me know if you would like to view the Shell Script. However, I know that the Shell Script is correct when run manually.

    Any information I could get on this would be GREATLY appreciated.

    Thanks a bunch,

    Clubber Lang

  2. #2
    Join Date
    Sep 2004
    Posts
    3

    In addition...

    I have been reading through some of the other threads on the LinuxQuestions forum. My problem seems to be very similar to this one:

    http://www.linuxquestions.org/quest...ghlight=crontab

    In bjdea1's final response he stated the following:

    sorry I found the cause. I have the main config file being accessed as "./config.file". No wonder everything else is failing because this config file is not being read at the very start of the program. Sorry I should have checked this more, thanks for your help.

    Since I am new this this, how is he accessing this config file? I do not have a /var/spool/cron directory. When I type the "su" command it reads: "su: user root does not exist". I also do not have a file in the /etc/crond.daily/ directory like wolf2554 mentions. It seems this is a very simple problem. I just don't know how to fix it...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •